X
Tap here to go to the mobile version of the site.

Support Forum

how do i get my start up language in english

Posted

when i open firefox my google box is not in english i will like to turn it back to english

This happened

Every time Firefox opened

== yesterday

when i open firefox my google box is not in english i will like to turn it back to english == This happened == Every time Firefox opened == yesterday

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • Winamp Application Detector
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1662
  • Shockwave Flash 10.0 r45
  • 2.0.31005.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java(TM) Platform SE binary
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

More Information

Morbus 135 solutions 2340 answers

Hi. I suppose you are located in a country that does not speak English and this behavior is due to Google's very annoying habit of changing into the native language of your location.

There are multiple ways to go around it, some more effective than others. The easiest way is to click "go to Google.com" or "Google in English" or something like that, when you visit google.com and it redirects you to google.somewherelse. You should also probably change your homepage to lead you to google.com. You can do that by going into Tools > Options > General.

There are also multiple extensions that will force Google to display in the language you want. I can name a few if you want.

Hi. I suppose you are located in a country that does not speak English and this behavior is due to Google's very annoying habit of changing into the native language of your location. There are multiple ways to go around it, some more effective than others. The easiest way is to click "go to Google.com" or "Google in English" or something like that, when you visit google.com and it redirects you to google.somewherelse. You should also probably change your homepage to lead you to google.com. You can do that by going into Tools > Options > General. There are also multiple extensions that will force Google to display in the language you want. I can name a few if you want.
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158860 answers

If the Google (Firefox) or Yahoo home page is in the wrong language then see: Google: http://www.google.com/support/bin/answer.py?answer=873 Yahoo: http://help.yahoo.com/l/us/yahoo/homepage/troubleshooting/troubleshoot-02.html

If the Google (Firefox) or Yahoo home page is in the wrong language then see: Google: http://www.google.com/support/bin/answer.py?answer=873 Yahoo: http://help.yahoo.com/l/us/yahoo/homepage/troubleshooting/troubleshoot-02.html

Helpful Reply

I keep getting dutch. Have removed and reinstalled multiple times.

I keep getting dutch. Have removed and reinstalled multiple times.

Helpful Reply

I'm in Indonesia, but I want my mozilla in english version, how can I change it?

I'm in Indonesia, but I want my mozilla in english version, how can I change it?
Morbus 135 solutions 2340 answers

You need to uninstall your current version and install the version you want (with the language you want). You can download them here:

http://www.mozilla.com/firefox/all.html

You need to uninstall your current version and install the version you want (with the language you want). You can download them here: http://www.mozilla.com/firefox/all.html

Question owner

None of the above suggestions help!

None of the above suggestions help!
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158860 answers

Some sites automatically redirect you to a site in the local language.
There is usually a link on such websites choose a language or go to an international version that allows to chose the language.
Clear the Google cookies: Tools > Options > Privacy > Cookies: "Show Cookies"

If the Google (Firefox) or Yahoo home page is in the wrong language then see:

Some sites automatically redirect you to a site in the local language.<br /> There is usually a link on such websites choose a language or go to an international version that allows to chose the language.<br /> Clear the Google cookies: Tools > Options > Privacy > Cookies: "Show Cookies"<br /> If the Google (Firefox) or Yahoo home page is in the wrong language then see: * Google: http://www.google.com/support/bin/answer.py?answer=873 * Yahoo: http://help.yahoo.com/l/us/yahoo/homepage/troubleshooting/troubleshoot-02.html

Modified by cor-el

Question owner

all menus of firefox are being displayed in hindi i want to get them back in english please forward a correct solution.

all menus of firefox are being displayed in hindi i want to get them back in english please forward a correct solution.
ferb82 0 solutions 1 answers

I think you can preview options in tools! Good luck! '''''''___

Hire Java Developer
I think you can preview options in tools! Good luck! ''''''''''''___ Hire Java Developer
rihckvarzdov 0 solutions 1 answers

Hi There. Try making this as your home page "http://www.google.com/ncr" (without the quotes).

In Firefox: Tools>Options>Under General tab set your Hompage to http://www.google.com/ncr

Hi There. Try making this as your home page "http://www.google.com/ncr" (without the quotes). In Firefox: Tools>Options>Under General tab set your Hompage to http://www.google.com/ncr