X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not shut down properly, requiring shut down through the Windows Task Master box.

Posted

Firefox will not shut down properly, requiring shut down through the Windows Task Master box. I've seen a "fix" for this problem indicating that we should just shut it down every time through the Task master box, but to me this isn't a FIX its just a "go around". Why can't tech support fix the problem with the application?

This happened

A few times a week

== I tried to open Firefox.

Additional System Details

Installed Plug-ins

  • -Pando Web Installer
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r45
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • DivX Web Player version 2.0.0.254
  • Exent® AOD Gecko Plugin
  • Nexon Game Controller 1.0.1.0
  • Next Generation Java Plug-in 1.6.0_19 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

http://support.mozilla.com/en-US/forum/1/646097?s=Firefox%20won%27t%20shut%20down.&as=q

TXGuy 87 solutions 861 answers

~~red:Hanging at exit~~

Kill Application In Task Manager, does firefox.exe show in the Processes tab? See: Kill Application

Causes and solutions for Firefox hanging at exit: Firefox hangs at exit (Mozillazine article) Firefox hangs or is not responding - How to fix "Firefox is already running but is not responding" error message - How to fix it

Safe Mode You may need to use Troubleshoot Firefox issues using Safe Mode (click on "Safe Mode" and read) to localize the problem. Firefox SafeMode is a diagnostic mode that disables extensions and some other features of Firefox. If you are using a theme, switch to the DEFAULT theme: Tools > Add-ons > Themes before starting Safe Mode. When entering Safe Mode, do not check any items on the entry window, just click "Continue in Safe Mode". Test to see if the problem you are experiencing is corrected.

See: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems Troubleshoot and diagnose Firefox problems

If the problem does not occur in Safe-mode then disable all of your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You have to close and restart Firefox after each change via File > Restart Firefox (on Mac: Firefox > Quit). You can use "Disable all add-ons" on the Safe mode start window.

~~red:Other Issues~~: to correct security/stability issues

Update Java: your ver. 1.6.0.19; current ver. 1.6.0.20 (important security update 04-15-2010) (Windows users: Do the manual update; very easy.) See: Updating Java Do the update with Firefox closed.

Question owner

Rather than doing a complete shut down, just log off and re log on, saves a bit of time anyway. It's worked for me. I'll definately try going back to the default theme though as I believe the trouble started when I chose a custom theme.