X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox-bin is still running when i close firefox, and consumes 99% of CPU

Posted

With almost any addon (skins not included), when i close my firefox, firefox-bin keeps running in the background, using 99% of my CPU. I use Linux (kubuntu) kernel 2.6.31-21-generic. I jhave to uninstall plugins and sometimes erase the mozilla folder in /home/"user". Any suggestions or help?

== i install any add-on

Additional System Details

Installed Plug-ins

  • -Shockwave Flash 10.0 r45
  • The Totem 2.28.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • The next generation Java plug-in for Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100407 Ubuntu/9.10 (karmic) Firefox/3.6.3

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Ubuntu Firefox Modifications
0.8
true
ubufox@ubuntu.com
Modified Preferences
Name
Value
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

Question owner

Yup, same here.

Ubuntu Lucid 10.04

Even sitting idle with firefox open is using 90% of my cpu.

Ridiculous

Question owner

Going to stop using firefox if issue is not fixed!!

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

You can create a new profile as a test to check if your current profile is causing the problems. See [[Basic Troubleshooting|#Make_a_new_profile|Basic Troubleshooting:Make a new profile]]

There may be extensions installed by default in a new profile, so check that in "Tools > Add-ons > Extensions".

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files). See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

kascade 0 solutions 1 answers

This is a major problem for mac users. This kind of error would totally prevent anyone using a mac from using Firefox.

For me at least, it's using an entire Gigabyte of memory on 'Firefox-bin'.

Emu 2 solutions 15 answers

Usual reason for this issue is bad written extension or plugin. Can you post the result of about:support page?

BradChesney79 0 solutions 1 answers

Same here CLI: top confirms 99-100% CPU usage. So far it hasn't diminished my browsing experience, but my laptop is getting hot which made me look at what was just plain running away with the goodies Gateway gave me.

 Application Basics
       Name
       Firefox
       Version
       4.0
       User Agent
       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
       Profile Directory
         Open Containing Folder
       Enabled Plugins
         about:plugins
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       Global Menu Bar integration
       1.0.2
       true
       globalmenu@ubuntu.com
       Ubuntu Firefox Modifications
       0.9
       true
       ubufox@ubuntu.com
       Hide Menubar
       4.0.20110415
       true
       hidemenubar@moztw.org
       Firebug
       1.7.0
       true
       firebug@software.joehewitt.com
       LastPass
       1.72.0
       true
       support@lastpass.com
       Rainbow
       1.0
       true
       rainbow@colors.org
       DownThemAll!
       2.0.2
       true
       {DDC359D1-844A-42a7-9AA1-88A850A938A8}
 Modified Preferences
     Name
     Value
       accessibility.typeaheadfind.flashBar
       0
       browser.places.smartBookmarksVersion
       2
       browser.startup.homepage
       http://www.google.com/
       browser.startup.homepage_override.buildID
       20110419192255
       browser.startup.homepage_override.mstone
       rv:2.0
       extensions.lastAppVersion
       4.0
       network.cookie.prefsMigrated
       true
       places.database.lastMaintenance
       1304145111
       places.history.expiration.transient_current_max_pages
       124603
       privacy.sanitize.migrateFx3Prefs
       true
 Graphics
       GPU Accelerated Windows
       0/1
TheRealRonin 0 solutions 2 answers

This worked for me :)

  • 1. Open Firefox
  • 2. In the address bar type in about:config
  • 3. A warning will appear, click the button that says “I will be careful” (if you already have not told it to warn you)
  • 4. Near the top of a VERY long list you will see an empty box next to the word Filter:
  • 5. Type in dom.ipc.plugins.enabled that will shrink the list down to 5 items
  • 6. The first one on the list is the one you are concerned with, right click on that entry and click on Toggle, that will change the value on the right from True to False
  • 7. Restart Firefox

Modified by TheRealRonin

rMatey 0 solutions 1 answers

Thanks RealRonin. It worked for me in ubuntu 10.04 LTS w/ FF 6.01

TheRealRonin 0 solutions 2 answers

Helpful Reply

No Problem glad it helped :), and this fix also works for Windows machines that have firefox.exe (Windows version of firefox-bin) still running. I have done this on my Ubuntu 10.04, Windows XP, Vista and 7 all with the same success, sadly I do not have a MAC to test it on.

Gerhard34 0 solutions 1 answers

Helpful Reply

It works sometimes, but not every time, though in dome.ipc.plugins.enabled always False is on. Sorry, this is no permanent solution.