Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox receives a 301 (permanently moved) when requesting google.com

  • 1 reply
  • 10 have this problem
  • 286 views
  • Last reply by Wikiwide

more options

When firefox sends a request for google.com, it receives a 301 (permanently moved) response, as detected by the Net log in firebug. The response redirects firefox to msdn.com. No other sites seem to have this problem, and it does not happen when using IE (although IE has its own issues). Firefox is also not configured to use a proxy. The problem seems to originate when firefox is starting up, and if it occurs when firefox starts, it consistently occurs for the entire session. Restarting firefox will sporadically correct it, but all bets are off for the next run. The computer has shown indications that it may have some kind of virus, but McAfee and SpyBot are not detecting it. Any help is greatly appreciated. Thanks!

This happened

Not sure how often

== Immediately after installation

All Replies (1)

more options

What about

typing "about:config" (without quotes) in the location bar/address bar/urlbar,

hitting Enter or clicking Go button

clicking "I'll be careful, I promise"

and then typing "msdn" (without quotes) as the filter in the textbox?

If there are any preference(s) below , then describe them/it. If there is nothing, don't be surprised; I expect so. Read on. ==

What about disabling all extensions and plug-ins? Go to Tools->Add-ons->Extensions and disable each of them. Go to Tools->Add-ons->Plug-ins and disable each of them. Then restart Firefox. Is the issue solved? Then you need to find the culprit among your extension and plug-ins.

Though I don't think it's related to the problem, you should update your Java and your Flash player.

Maybe, you use openDNS or a proxy or something like that? It could be cause of the problem.

I just googled the issue and found: http://forums.opendns.com/comments.php?DiscussionID=226&page=2 ====

Or try to change homepage to http://google.com/ or http://www.google.co.uk/ A similar issue is described here: http://code.google.com/p/chromium/iss.../detail?id=36869#c3