X
Tap here to go to the mobile version of the site.

Support Forum

Mac OS X 10.3.9 (7W98) corrupt file how can I use

Posted

I tried to install firefox on my computer Max OS X 10.3.9 and it says that the file is corrupt. I do not have firefox presently installed on my computer. I would like to use firefox is there a version that I can use or is my computer to old?

== I tried to install firefox on my computer Max OS X 10.3.9 and it says that the file is corrupt

I tried to install firefox on my computer Max OS X 10.3.9 and it says that the file is corrupt. I do not have firefox presently installed on my computer. I would like to use firefox is there a version that I can use or is my computer to old? == I tried to install firefox on my computer Max OS X 10.3.9 and it says that the file is corrupt

Additional System Details

Installed Plug-ins

  • -Adobe PDF Plug-In For Firefox and Netscape
  • Java(TM) Platform SE binary
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

I tried to install firefox on my computer Max OS X 10.3.9 and it says that the file is corrupt

the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40084 answers

Firefox 2.0.0.20 is the last ever release for Mac OSX 10.3.9 and earlier versions. Get it here: http://download.mozilla.org/?product=firefox-2.0.0.20&os=osx&lang=en-US

Firefox 2.0.0.20 is the last ever release for Mac OSX 10.3.9 and earlier versions. Get it here: http://download.mozilla.org/?product=firefox-2.0.0.20&os=osx&lang=en-US