Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My browser has been hijacked by wellaction.com ,I can not update my windows this thing keeps redirecting me ,Spybot won't work it won't update either.Any suggestion how to get rid of it.And it looks like another creep on the block D Powell

more options

My browser has been hijacked by wellaction.com ,I can not update my windows this thing keeps redirecting me ,Spybot won't work it won't update either.Any suggestion how to get rid of it.And it looks like another creep on the block D Powell Avg can't find it HELP!!

This happened

Every time Firefox opened

== 3 day's ago

All Replies (8)

more options

Do a barrel roll! Go through 12 hours trying to get malware antivirus programs to work. Bring it in to tech support, where they'll recommend you get $1200 hardware to fix your computer and retrieve the info on it. Or

Do a system restore.

Spend those 24 hours saved playing diablo 2/starcraft 3 if on windows.

Spend those 24 hours saved trying to find someone who will hire you without windows skills if you are using mac.

combofix also works...

more options

did you manage to get any help with this ???

more options

this wellaction thing is hitting loads of computers my malware protection IS NOT doing anything what are we supposed todo.

more options

Did any of this manage to work for anyone?

more options

I had this problem and it was solved by local computer shop. The computer was okay it turned out that the router had been infected with a virus and changed settings. The password was changed settings corrected and I have had no further trouble.

more options

I am on a MAC system and have this same Wellaction.com problem at a couple of sites when I am using Safari and Foxfire. I took my computer in to an Apple dealer and was told that there were no known Apple viruses... yet I had the problem non-the-less. They did suggest that I unplug my router for 10 minutes and then let it reset. I did that and sure enough Wellaction was back. Do I need to call Comcast who provided the router?

more options

here's a test for you disconnect your router network direct to your server and see if Wellaction shows up

more options

its getting REALLy annoying when i try to surf the web