X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't access a site. Receive Error code: sec_error_revoked_certificate

Posted

FF version 3.6.3 on 2kPro

The certificate on the site I am accessing expired and was replaced yesterday. I can access the site from IE and see that it has updated the certificate information but I cannot from FF. I tried deleting the old certificate in hopes that it would load the new one, no Joy. Also restarted FF, no help.

Operating system

W2K

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

More Information

Helpful Reply

Secure Connection Failed







An error occurred during a connection to myvodafone.vodafone.in.

Peer's Certificate has been revoked.

(Error code: sec_error_revoked_certificate)





   *   The page you are trying to view can not be shown because the authenticity of the received data could not be verified.
   *   Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

Question owner

It is our site. We think it is an issue with FF as IE verified the new certificate without problem. It may be a difference in how the certificates are verified. The FF browser eventually accepted it. We find it hard to believe that the propagation of the new certificate did not complete overnight but...

In my original request I stated: I tried deleting the old certificate in hopes that it would load the new one. What I deleted was an exception certificate I had loaded before we installed the certified one. Anyway, I am updating this as I believe FF and Mozilla share this problem. One of our users had the same issue with Mozilla. No one else reported a problem so we are assuming they are IE users.

Question owner

when I try to launch Firefox , I get a box tht pops up in center of screen with Has a blue and yellow sheild in left had corner of the box, that says User Account Control. Then there is a blue bar with a Question mark in a Shield that Reads Do you want to allow the following program to make changes to this computer?

It shows a firefox globe and says Program Name: Firefox Verified Publisher Mozilla Corporation File Origin Hard Drive on this computer

Show Details and a yes or No


Change when these notifications appear


I have tried everything to get rid of this box, every time try to open firefox I get this message, If I try to open a new window I get this message

Any suggestion on how to get rid if this notifatiion .

nedbaugh 0 solutions 1 answers

I saw this error with Firefox only - IE, Safari, Chrome all accepted the cert. Disabling OCSP validation in Firefox allowed it to work, but I didn't want to have to tell customers to disable security in their browser to log into their accounts.

My setup: ISA 2k firewall server, new Win 2008R2 server running IIS7 in back. SSL bridge between firewall and new server, certificates purchased from GoDaddy. Because upgrading to 2008 in effect meant moving the certificate to a new server, I had to rekey, download and reinstall the new certificate. Because other browsers were accepting the new certificate as valid, it didn't occur to me that I'd have to update the certificate on the ISA server as well. When I exported the certificate from the 2008 server and imported it to the private store of the ISA server, I was then able to reconfigure the external listener for that website and Firefox accepted it.

Handy trouble-shooting site for this is:

https://www.ssllabs.com/ssldb/index.html

My site's still not getting an "A" rating from them, but at least it's good enough for Firefox to accept the certificate.

(also - this might not be relevant for everyone, but this page was also helpful in spelling out the specific steps to set up the ssl bridge between ISA2k and IIS7: http://www.isaserver.org/tutorials/Configuring_SSL_Bridging.html#)

Modified by nedbaugh