X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I CANNOT CLOSE THE FIRST TAB WHEN I SEARCH FOR SOMETHING AND CLOSE A SECOND TAB IT WILL NOT LET ME CLOSE THE FIRST TAB

Posted

I CANNOT CLOSE THE FIRST TAB AFTER I TYPE IN A SEARCH

This happened

Every time Firefox opened

== I UPGRADED TO 3.6

Chosen solution

Is it possible that some extension is causing the problem?

Try running Firefox on safemode to disable all extensions to see if that fixes the issue. If it does, try disabling one extension at a time to see which one is causing the problem, then disable it for good and contact its author for support.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • Coupons, Inc. Coupon Printer DLL
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.0 r12
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java Plug-in 1.6.0_05 for Netscape Navigator (DLL Helper)

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 (.NET CLR 3.5.30729)

More Information

Morbus 134 solutions 2338 answers

Chosen Solution

Is it possible that some extension is causing the problem?

Try running Firefox on safemode to disable all extensions to see if that fixes the issue. If it does, try disabling one extension at a time to see which one is causing the problem, then disable it for good and contact its author for support.

waynecz 0 solutions 25 answers

I have the same issue and it just started with the last update to Firefox that was just done automatically within the last week (week of 10/24/10). The only way I can get it to go away is to close all the tabs that are open open and that kind of defeats the purpose of tab browsing don't ya think? If I have multiple web pages open it does not necessarily do it to the first tab of all of them, typically, it appears to do it to the first tab on the first set of tabs opened. I tried dragging it to a new window and it did go, but also stayed as a blank page from the set of tabs I dragged it from. It is highly annoying and if I close out the tab will try to reload when Firefox is reopened (but it can be deleted there before it loads completely).

Mozilla Firefox 3.6.12 version Windows 7 Ultimate 64 bit

Oh and the standard answer of disable all extensions and re-enable them one at a time is a bunch of b.s. That's the computer "help" answer for everything. Windows help always tells you to start all over clearing everything too (complete reboot), as does every software company. It's never anybody's problem, always caused by some other company's software or hardware lately in the computer world.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

If you can't close a tab then you have either malware or an extension preventing it.
If you won't test it in Troubleshoot Firefox issues using Safe Mode then that is your choice and you won't be able to verify if it is an extension or something else. We would see countless reports if it is a problem with a bare Firefox installation without any customization added either by yourself or some external (security) software or even worse by a malware infection.

joshturley 0 solutions 1 answers

I'm also having this same problem. The only way to get the tab to close is to close firefox completely. You can hit the X on the tab, and then continue using it to browse.

It's interesting, you can still close other tabs, just not the first one when multiple tabs are open. I'm also on the latest version of firefox.

That being said, it's intermittent. I'm able to fire up firefox and have it work, then something triggers it to stop working while I'm browsing the web. As for the trigger, I haven't come any closer to discovering it.

frankd14612 0 solutions 12 answers

Helpful Reply

I have the same problem and tested it in Safe Mode, and did the disable the add-ons thing. Everything went OK, even up to the last add-on. There wasn't a hint of the problem anymore, so I went back to regular use of FF (3.6.12) again. WELL, THE SAME THING HAPPENED AGAIN!!! I agree with the person who said that your supposed troubleshooting is B.S. You blame the user instead of saying something useful like "OK, we heard you (and over two dozen others) and we know it's not your doing, and it's OUR PROBLEM, and we're going to look into it and figure out how to fix it, AND we'll get back to you when we do and tell you how to fix it too." THAT's the kind of answer we FF users want to hear, not some claptrap about how WE the users didn't try hard enough to fix it on our own!

LorraineJoubert 0 solutions 14 answers

I have the same problem - after the latest Firefox update. BUT the reason why I want to close the first tab is because it does not load! It keeps on loading and loading. So the first tab does not load and it does not close! All other tabs load and close. This happend when I open new tabs or when FF opens previous sessions.

If it is an add-on i suggest FF tell us which add-on they made their browser incompatible with. If I cannot use add-ons with FF, or need to close and reopen all add-ons every time FF mess-up, I shall change to Chrome. The reason why I am using FF, is because of all the extensions I am using.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

If you use a custom theme then switch to the default theme (Tools > Add-ons > Themes).

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Kif 1 solutions 20 answers

Helpful Reply

I have been running two machines with Firefox 3.6.12, and both have this problem with tabs refusing to close. It does not necessarily affect the first tab to be opened, although it is clearly the most commonly affected. Only one tab per browsing session is malfunctioning (I have not experienced multiple tabs failing to close when requested), and as others have experienced, Firefox as a whole has to be closed and restarted. When Firefox is instructed to close, the tab will also close, and does not impede the closure of the browser.

'Locking' (to coin a phrase) has been occurring more often than not, but the phenomenon is otherwise random. Using Safe mode does not seem to exhibit the problem (although I have not tested this extensively), but nor does it cure it; loading a full version after or along side a Safe version makes no difference. Switching off Add-ons appears to make little difference either, but given the randomness of the issue it is hard to test conclusively, because one cannot predict whether loading Firefox will result in a 'locked' tab or not before the browser is running. Consequently, one might be led to believe that switching off an Add-on has helped, but in fact the 'locking' of a tab may not have manifested itself on that occasion anyway.

The problem began with 3.6.11, and updating to 3.6.12 (which I hoped may cure the problem) seems to have made it worse. However, this is an anecdotal rather than an empirical observation.

Notable indicators that a tab has become 'locked' are:

1/ that the website url icon to the left of the tab name is blank

2/ that the "Reload All" Add-on does not work on the locked tab, but does on all other open tabs

3/ that on occasion the Back and Forward NavBar buttons do not work or are 'unlit' even if the tab has displayed more than one page during the session

4/ that the 'locked' tab may try to load a new page from user-selected link, but never completes the task, and since it cannot be closed would continue ad infinitum unless Firefox itself is closed by the user.

Combinations of 1-4 can be varied, as the 'symptoms' are just as unpredictable as the 'illness'. However, the missing url icon (1) and ignoring Reload All (2) appear so far to be universal indicators with all locked tabs. [Not so. See later posting for updated report - K]

Given the recentness of the issue I have reinstalled 3.6.10 on my desktop machine over the top of 3.6.12, without changing any of the Add-ons, and so far it has not exhibited the problem in the last two days. My laptop, still using 3.6.12 and with the same Add-ons, is still experiencing locked tabs on a regular, but unpredictable, basis.

My conclusion is that Firefox 3.6.11 and 3.6.12 are in some way flawed, and/or have become incompatible with the Add-ons rather than the Add-ons being incompatible with Firefox. This would not indicate a user error.

I would personally recommend users download and install 3.6.10 over the more recent versions.

Kif

Add-ons installed:

Adblock Plus 1.3.1 Crawler Toolbar 1.3 Fox Clocks 2.6.18 FoxTab 1.3 Google Toolbar 7.12 (etc) Google Tab Remover 1.9.5 Invisible Hand 2.8 Java Console 6.0.22 Java Quick Starter 1.0 Microsoft Net Framework Asst. 1.2.1 New Tab Homepage 0.4.2 Norton IPS 2.0 Reload All! 0.9.5.1

Modified by Kif

frankd14612 0 solutions 12 answers

I had the same problem. I solved it by uninstalling TabMix Plus (0.3.8.4). In its place I installed Multiple Tab Handler (0.5.2010070301).

Kif 1 solutions 20 answers

Hi Frankd.

I'm pleased that you found a solution, but given that I am running neither of the Add-ons you named on either of my PCs, that doesn't seem to account for the problem, unless the mere process of uninstalling and re-installing Add-ons somehow re-aligns them to Firefox 3.6.12 or vise versa.

That could be a tedious process, since Firefox will need to be restarted for every Add-on removal, so I will continue with 3.6.10 (which is still running fine on my desktop PC) for the time being, and will reinstall '10' on my laptop once I'm confident that it remains more stable than '12'. But thanks all the same for your help.

-K-

frankd14612 0 solutions 12 answers

Kif,

I'm not pleased anymore. :( The "fix" did not hold. Nothing I've tried has worked. It's not due to add-ons. I have two machines, one WinXP Pro (old) and one Win 7 (new). Both are using Firefox 3.6.12 (which is the latest version at this time) with all different add-ons, and BOTH have the same, identical problem with the unclosable tab. So the problem and its fix are the responsibility of Mozilla, not its end-users.

Frank

Kif 1 solutions 20 answers

Okay, Frank - thanks for the update. I'm using XP SP3 on both my machines, BTW.

Sorry to hear that the fix didn't work. As I mentioned above, I think the randomness of the problem may have given the impression that your fix had worked because the tab 'lock' fault didn't occur when FFox was restarted, so all seemed well at the time.

As an update to my earlier post, I've found that the blank tab icon to the left of the tab name is not a universal feature of a 'locked' tab; I've since had an occasion where the website's own url icon was present, but the tab still refused to close. And just to be clear, by "blank" I do not mean "missing".

So far, then, only the inability for the 'Reload All' Add-on to work on locked tabs has been the consistent feature I've found with this problem, other than the problem itself. Otherwise 'locking' may sometimes be completely undetectable until the user wishes to close the affected tab.

So far 3.6.10 still seems to be holding up on my desktop machine. Assuming you haven't done so already, it may be helpful, given you are also using two machines with 3.6.12 (albeit with different OS's), if you tried running one with '10' to compare alongside running '12' on the other. Apart from one setting (the spellcheck as you go option), all my other settings appear to have remained intact after installing '10' over the top of '12'. I did not uninstall the later version first, so did not need to make other changes. If your version of '10' also behaves better than your version of '12', then that would support the notion that 3.6.12 is the root of the problem if the Add-ons remain constant. However, if '10' is no better for you than '12', then perhaps there is indeed some issue with the Add-ons. So far I only have my own experience to go on, so can therefore only report accordingly.

Hope that's some help, though like yourself I'd rather Mozilla take a proper look at this, not least to identify which Add-on(s) (if any) may be in conflict if they are certain that 3.6.12 is not faulty. I can't avoid noticing that the number of users with this problem is on the rise.

Kif

Modified by Kif

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

You can try to disable JavaScript temporarily and see if you can close the tab with a double click on that tab on the tab bar.

Modified by cor-el

frankd14612 0 solutions 12 answers

Kif,

As you suggest, I'll try going back to FF 3.6.10 (on my Win 7 machine) and see if there's any difference.

Frank

frankd14612 0 solutions 12 answers

Cor-el,

I tried disabling Javascript and double-clicking on the unclosable tab but nothing happened. I also tried "Close Tab" and "Close All Tabs" from the context menu, but nothing happened there either.

frankd14612 0 solutions 12 answers

Kif,

I tried your suggestion on my Win 7 machine: "Assuming you haven't done so already, it may be helpful, given you are also using two machines with 3.6.12 (albeit with different OS's), if you tried running one with '10' to compare alongside running '12' on the other." However, there was absolutely NO change to the Unclosable Tab situation. I also tried uninstalling the TabMix Plus add-on, using no tab add-on whatsoever, and then tried using the "Tabberwocky" add-on. Under NO set of conditions was there any change to the problem. It's as if Firefox does not see the unclosable tab as a tab. It's as if it's below the browser's radar and therefore not subject to any of its rules. As someone has already pointed out, there is also the rotating circle icon at the left corner of the UT which indicates that it's constantly trying to update its contents. Now, as a workaround, if there was some way to minimize this tab's width to 0, that might be a practical way of getting around the problem. Until then I guess we're doomed to living with it.

Frank

frankd14612 0 solutions 12 answers

News:

I don't know how long this will hold, but I've been able to make the problem go away (on my Win 7 machine with FF 3.6.10). I didn't realize how much of a relief it would be!

What I did was to get rid of three add-ons I felt I didn't need: Force TLS 2.0 Invisible Hand 2.8 YouTube to MP3 1.0.7

Now I'll try it on my Win XP machine and report back.

Kif 1 solutions 20 answers

Hi.

With some irony, when I logged on to read Frank's messages the tab for this page locked on my desktop, which is running 3.6.10. The Mozilla tab icon was present, so there was no indication it had locked until I tried to close it.

However, it is the first time this has happened under '10' since I re-installed it six days ago, whereas my laptop, still running '12', has produced a locked tab in virtually every session. So 3.6.10 still appears the better option, and it seems Frank has had some joy from using it, too.

As I am also running Invisible Hand on both machines, I'll uninstall that on my laptop to see if '12' behaves better without, although I did disable it when the problem first arose when my desktop was using '12', and it didn't seem to make a difference. I'll also see if disabling Javascript will replicate Frank's lack of success in that department, if only to remove it as a probable cause. However, having to disable Javascript each time in order to close a locked tab is hardly an ideal solution, and is probably more of a nuisance to perform than simply closing and reloading Firefox itself. Of course, it would be better if tabs weren't locking-up in the first place.

Unfortunately, being a Sunday, I will not have a great deal of time to devote to this today, so my progress report will be delayed.

-K-

frankd14612 0 solutions 12 answers

GOOD NEWS: I've been operating all day, with 5-6 reboots of my Win 7 machine and 8-10 restarts of FF 3.6.12, and the "fix" is still working. No Unclosable Tabs today! :)

I also uninstalled the Invisible Hand 2.8 add-on from FF 3.6.12 on my Win XP machine (the only add-on the two machines had in common), and after using FF all day with about 5 reboots and 10 restarts I've had the same good luck. :)

I'll keep working and report back.

Frank

Kif 1 solutions 20 answers

Hi Frank. Thanks for the update.

Can I just get a little something cleared up? You were running 3.6.10 on your Win7 machine ( November 13, 2010 10:44:04 AM PST), but your latest post says it is running 3.6.12. Can you confirm that you have re-installed 3.6.12 on that machine so that both the Win7 and XP PCs are using '12' again? Many thanks.

Not had a chance yet to properly test '12' without Invisible Hand 2.8 on my laptop yet, but it may take a while to be certain whether that does the trick because of the randomness of the problem, and the opportunity to test. My desktop running '10' with IH2.8 still installed (which is the machine I'll be using most today) has been fine so far after yesterday's hiccup.

My laptop had a locked tab yesterday too, for the brief time I was using it for browsing, but that was before I removed IH2.8, so basically it was acting in keeping with recent behaviour. The locked tab also had the url icon in place (i.e. it wasn't the blank default), so again I had no clue that it had locked until I tried to close it. I ran Reload All!, which confirmed it was not functioning properly. The Reload All! Add-on is still the only diagnostic I've found that indicates that a tab has really locked, and not that (for some other reason) a click on the X or other command simply hasn't taken first time on a properly functioning tab.

The testing goes on...!

Kif