Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Nightly - Azure - Logic Apps - Cannot Move Actions

  • 5 replies
  • 0 have this problem
  • 4 views
  • Last reply by Mike Kaply

more options

Description When trying to move an action, anywhere, in the Logic Apps Designer View it displays a 'nope' circle (🚫) and will not move the action.

This occurs on multiple tenancies for multiple clients and is affecting my ability to easily produce work for them.

Logged Elsewhere? I have raised this with Microsoft, here, and am assuming that this is the best place to raise it with yourselves, here.

Steps to Reproduce the Bug or Issue

  1. Build Logic App with actions
  2. Ensure that there are parallel tasks
  3. Attempt to move an action

Additional context Further Details

This was working a week ago or so.

I have also seen issues with the V2 Designer in Power Automate, too. There the 'experimental features' expression builder does not fulfill autofil on function suggestions or quote closing.

This makes me concerned that it might be a more pervasive change in how javascript is being handled by the browser, rather than changes at Microsoft's end.

However, I would not put out of my mind that they are restricting FireFox functionality due to new designers, and browsers, etc.

FireFox Type: Nightly Version: 124.0a1 (2024-01-31) (64-bit) Add-ons: Multiple-Account Containers

Edge Type: Microsoft Edge for Business (Chromium) Preview releases: Yes Version: Version 122.0.2365.16 (Official build) stable app, beta channel (64-bit)

'''Description''' When trying to move an action, anywhere, in the Logic Apps Designer View it displays a 'nope' circle (🚫) and will not move the action. This occurs on multiple tenancies for multiple clients and is affecting my ability to easily produce work for them. '''Logged Elsewhere?''' I have raised this with Microsoft, '''[https://github.com/Azure/logicapps/issues/983 here]''', and am assuming that this is the best place to raise it with yourselves, here. '''Steps to Reproduce the Bug or Issue''' # Build Logic App with actions # Ensure that there are parallel tasks # Attempt to move an action '''Additional context''' ''Further Details'' This was working a week ago or so. I have also seen issues with the V2 Designer in Power Automate, too. There the 'experimental features' expression builder does not fulfill autofil on function suggestions or quote closing. This makes me concerned that it might be a more pervasive change in how javascript is being handled by the browser, rather than changes at Microsoft's end. However, I would not put out of my mind that they are restricting FireFox functionality due to new designers, and browsers, etc. ''FireFox'' Type: Nightly Version: 124.0a1 (2024-01-31) (64-bit) Add-ons: Multiple-Account Containers ''Edge'' Type: Microsoft Edge for Business (Chromium) Preview releases: Yes Version: Version 122.0.2365.16 (Official build) stable app, beta channel (64-bit)
Attached screenshots

All Replies (5)

more options
        1. Potentially Relevant Errors
          1. Origin is not a trusted origin

Looking in Dev Tools there is a "_Origin is not a trusted origin_" error, could that be related?

I have the security up nice and high, so perhaps it is preventing a perceived XSS issue?

``` Origin is not a trusted origin. Session: origin:https://ema.hosting.portal.azure.net [DesignerFramePage.js:81:32](https://ema.hosting.portal.azure.net/ema/Content/2.40122.1.5/Scripts/Workflow/ViewModels/FramePages/DesignerFramePage.js)

   eventListener https://ema.hosting.portal.azure.net/ema/Content/2.40122.1.5/Scripts/Workflow/ViewModels/FramePages/DesignerFramePage.js:81
   (Async: EventListener.handleEvent)
   createFrameManager https://ema.hosting.portal.azure.net/ema/Content/2.40122.1.5/Scripts/Workflow/ViewModels/FramePages/DesignerFramePage.js:95
   <anonymous> https://ema.hosting.portal.azure.net/ema/Content/2.40122.1.5/Scripts/Workflow/ViewModels/FramePages/DesignerFramePage.js:1242
   <anonymous> https://ema.hosting.portal.azure.net/ema/Content/2.40122.1.5/Scripts/Workflow/ViewModels/FramePages/DesignerFramePage.js:1244

```

          1. DNS over HTTPS

Disabling this, or adding the sites made no difference.

          1. DNS General

In case it made any difference I have used a different DNS provider to my default, and it was the same on Cloudflare's `1.1.1.1`.

Helpful?

more options

eliot.cole said

I have the security up nice and high

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

eliot.cole said

This was working a week ago or so.

You can use mozregression to find when it stopped working to help identify the cause.

Helpful?

more options

I just made a new profile, and no, it does not fix it. It is the same.

Sorry, that mozregression thing is too much. I'm at work and don't have the time to learn a piece of software to check exactly when this stopped working.

If no-one at Mozilla can work on this, then fine ... but at least I know that I've raised it and that it is an issue.

Even if I have no idea if this is the right place to have done so. 😅

---

In the Microsoft GitHub issue they note that the code of the ('classic') designer has not changed for a long time now.

Incidentally they closed the issue quoted in the original post, and this is the currently open one: https://github.com/Azure/LogicAppsUX/issues/4154

Modified by eliot.cole

Helpful?

more options

Hi

Thank you for using a Nightly build of Firefox and helping to test future updates. I recommend that you report this issue as a bug so that our developers can look into it further. This support article should help:

https://support.mozilla.org/en-US/kb/file-bug-report-or-feature-request-mozilla

Helpful?

more options

Eliot: would you be willing to walk me through creating a basic logic app to recreate this? I have the Azure subscription, but this is a pretty unknown area for me.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.