Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Popup closes after opening

  • 2 replies
  • 0 have this problem
  • 7 views
  • Last reply by cor-el

more options

When I doubleclick an image in Azure DevOps, it's supposed to open fullscreen in a popup/tab. That popup opens, and immediately closes afterwards.

How do I fix this?

Popups are explicitly allowed on this site, but it doesn't make a difference. I have tried turning off content blockers, and changing between strict and standard privacy settings.

I don't really want to go on a wild goose chase and try a billion different things. Rather, I'd like to know how to diagnose this. So how can I know what mechanism is responsible for closing the popup. This will allow me to narrow my diagnosis a great deal.

It would also help to know how I can 100% prevent anything other than the user from being able to close a tab. Just to test what happens inside that popup. Because how can I know what's going on in a popup that lives for a few milliseconds? I'm not that fast.

When I doubleclick an image in Azure DevOps, it's supposed to open fullscreen in a popup/tab. That popup opens, and immediately closes afterwards. How do I fix this? Popups are explicitly allowed on this site, but it doesn't make a difference. I have tried turning off content blockers, and changing between strict and standard privacy settings. I don't really want to go on a wild goose chase and try a billion different things. Rather, I'd like to know how to diagnose this. So how can I know what mechanism is responsible for closing the popup. This will allow me to narrow my diagnosis a great deal. It would also help to know how I can 100% prevent anything other than the user from being able to close a tab. Just to test what happens inside that popup. Because how can I know what's going on in a popup that lives for a few milliseconds? I'm not that fast.

All Replies (2)

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

I notice that you have a userChrome.css file.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window