Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox displays in forien langue

  • 1 reply
  • 10 have this problem
  • 104 views
  • Last reply by cor-el

more options

For some reason Firefox is now displaying in some strange langue. I have gone to settings, langues and have English selected. This should have corrected the problem but it has not. I have gone through the alternate langues menu and have what I believe to be English CA selected. Still a problem?

What else can I do?

For some reason Firefox is now displaying in some strange langue. I have gone to settings, langues and have English selected. This should have corrected the problem but it has not. I have gone through the alternate langues menu and have what I believe to be English CA selected. Still a problem? What else can I do?

All Replies (1)

more options

Is this about the language for the user interface or only about the language for webpages (browsing area)?

This could be a font problem.

Can you attach a screenshot?