Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Links don't open upon first startup of Firefox.

  • No replies
  • 2 have this problem
  • 10 views
more options

Firefox is my default web browser. When I turn on my computer to check my emails in the morning, I usually have links sent by friends/family or work. I have always been able to simply click the link and when Firefox opens it goes straight to the link. Not since the latest update. Firefox opens, but the tab remains blank as if I never clicked the link. I have to go back to my email app and re-click the link for Firefox to open it. Then it does. It will open the link as well if I open up Firefox beforehand. I tried to Refresh and default every setting but Firefox remains unable to open links upon first startup. I also deleted and re-installed Firefox but I continue to have the issue. Any ideas? Thanks!

Firefox is my default web browser. When I turn on my computer to check my emails in the morning, I usually have links sent by friends/family or work. I have always been able to simply click the link and when Firefox opens it goes straight to the link. Not since the latest update. Firefox opens, but the tab remains blank as if I never clicked the link. I have to go back to my email app and re-click the link for Firefox to open it. Then it does. It will open the link as well if I open up Firefox beforehand. I tried to Refresh and default every setting but Firefox remains unable to open links upon first startup. I also deleted and re-installed Firefox but I continue to have the issue. Any ideas? Thanks!

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.