Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

File has been blocked from being loaded in message

  • 3 replies
  • 0 have this problem
  • 31 views
  • Last reply by Toad-Hall

more options

I have "allow remote content" enabled yet these warnings still appear. All of the emails in my work inbox are from a trusted source, therefor these warnings do not serve any purpose and are more annoying than beneficial. For some reason I can't use the element inspector in developer tools on this window but if I could hide the warning with a userchrome.css file that would also be nice too. I have tried that but it didn't seem to do anything. Here is what I did.

  1. mail-notification-top{

display: none; }

I also have toolkit.legacyUserProfileCustomizations.stylesheets set to true (not sure why this isn't the default setting to avoid confusion)

I have "allow remote content" enabled yet these warnings still appear. All of the emails in my work inbox are from a trusted source, therefor these warnings do not serve any purpose and are more annoying than beneficial. For some reason I can't use the element inspector in developer tools on this window but if I could hide the warning with a userchrome.css file that would also be nice too. I have tried that but it didn't seem to do anything. Here is what I did. #mail-notification-top{ display: none; } I also have toolkit.legacyUserProfileCustomizations.stylesheets set to true (not sure why this isn't the default setting to avoid confusion)
Attached screenshots

All Replies (3)

more options

Not sure why the warning is shown if all remote content is allowed, but to hide it, try this in your userChrome.css:

#mail-notification-top {
display: none !important;
}

https://www.userchrome.org/download-userchrome-css.html

To change the alert background color:

@namespace html url("http://www.w3.org/1999/xhtml");
html|div.container.infobar[role="alert"] {
  background-color: pink !important;
}
more options

sfhowes said

Not sure why the warning is shown if all remote content is allowed, but to hide it, try this in your userChrome.css:
#mail-notification-top {
display: none !important;
}

https://www.userchrome.org/download-userchrome-css.html

To change the alert background color:

@namespace html url("http://www.w3.org/1999/xhtml");
html|div.container.infobar[role="alert"] {
  background-color: pink !important;
}

I've tried the first style sheet but sadly it doesnt appear to do anything. Honestly I think this warning message should be changed from blocking the files contained in a forwarded message to just simply asking if they want to be included. This is actually a standard email client practice to ask the user if they want to include the files or not. But thunderbird instead just blocks them and prompts you to overide this behavior. When I made this post I thought this was a random error message but that was really due to my misunderstanding of this behavior.

more options

That does not sound like the usual remote content error.

It looks like you have clicked on 'Reply' or 'Forward' and a 'file' is being blocked, so this could be a signature file.

Do you use a signature html file ? In Account Settings > select name of account in left pane On the right have you selected checkbox 'Attach the signature file from a file instead' ?

Did you create that signature file using Thunderbird 'Write' mesasge window and save as html file? If no: you did not use the 'Write' window in Thunderbird to create that signature html file, then it's possible the html code actually points to a file on your computer eg: file:///C:/Users/username/Documents/TB Signatures/Business.html or points to an image file in same way: file:///C:/Users/username/Documents/TB Signatures/Business.jpg

Try this to fix so file gets properly attached. Recreate that signature file and this time use Thunderbird Write message window to create it and then save as file - choose location and save as html file. Then set up Account Settings to use that file.

Modified by Toad-Hall