Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

US Goverment website doesn't support Firefox ESR 102.10.0esr (Debian)

  • 1 reply
  • 0 have this problem
  • 1 view
  • Last reply by cor-el

more options

My platform is Debian 11.6: My FireFox install is 102.10.0esr (64-bit)

I was assisting my wife in making an appointment at the US Embassy in Manila via the US Embassy website. It all worked correctly *until* I chose the appointment day and time and clicked to continue. Rather than confirm the appointment, it told me I needed an up-to-date browser that supported 128 bit encryption. Now I know FireFox does support that. The screen looked like it thought I was using Netscape!

I switched to Chrome (much to my annoyance) and the website worked. This is not the first time I have found that I have to abandon FireFox to do something when using it on Linux. I haven't been on Windows for a while, but I don't remember this problem on that platform. This is a real problem. Please fix it. There is no reason why a website should think FireFox is Netscape.

My platform is Debian 11.6: My FireFox install is 102.10.0esr (64-bit) I was assisting my wife in making an appointment at the US Embassy in Manila via the US Embassy website. It all worked correctly *until* I chose the appointment day and time and clicked to continue. Rather than confirm the appointment, it told me I needed an up-to-date browser that supported 128 bit encryption. Now I know FireFox does support that. The screen looked like it thought I was using Netscape! I switched to Chrome (much to my annoyance) and the website worked. This is not the first time I have found that I have to abandon FireFox to do something when using it on Linux. I haven't been on Windows for a while, but I don't remember this problem on that platform. This is a real problem. Please fix it. There is no reason why a website should think FireFox is Netscape.

All Replies (1)

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window