Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

UserChrome.css not loading

  • 5 replies
  • 0 have this problem
  • 1 view
  • Last reply by Terry

more options

I read somewhere UserChrome.css is not official part of Firefox but I would greatly appreciate an answer.

I have set toolkit.legacyUserProfileCustomizations.stylesheets to true, and userChrome.css file is located here: C:\Users\<my name>\AppData\Roaming\Mozilla\Firefox\Profiles\********.default\chrome\ ,which is the folder pointed out by Firefox in the help menu.

I don't know what would be the most reliable way to test if the file is loaded. I have tested it with these:

 #context-openlinkintab { display:none!important; }
 #TabsToolbar{ background-color: #CCCCCC !important }

Neither change occurs so I assume UserChrome is not loaded.

I created a fresh profile and tested with it, but still no changes in UI. Yes, I did remember to use correct settings in this new profile.

Is this depreciated in Firefox 111 or what might be the problem?

When I open Settings it says: "Your browser is being managed by your organization." I wonder what this means, where did it come from and could this be the problem?

When I open that link there's one entry: Policy Name Policy Value Certificates ImportEnterpriseRoots true

Any help?

I read somewhere UserChrome.css is not official part of Firefox but I would greatly appreciate an answer. I have set '''toolkit.legacyUserProfileCustomizations.stylesheets''' to '''true''', and '''userChrome.css''' file is located here: C:\Users\<my name>\AppData\Roaming\Mozilla\Firefox\Profiles\********.default\chrome\ ,which is the folder pointed out by Firefox in the help menu. I don't know what would be the most reliable way to test if the file is loaded. I have tested it with these: #context-openlinkintab { display:none!important; } #TabsToolbar{ background-color: #CCCCCC !important } Neither change occurs so I assume UserChrome is not loaded. I created a fresh profile and tested with it, but still no changes in UI. Yes, I did remember to use correct settings in this new profile. Is this depreciated in Firefox 111 or what might be the problem? When I open Settings it says: "Your browser is being managed by your organization." I wonder what this means, where did it come from and could this be the problem? When I open that link there's one entry: Policy Name Policy Value Certificates ImportEnterpriseRoots true Any help?

All Replies (5)

more options

Technically you should contact the site that you downloaded the userChrome.css for support in using their edits. And usually that "user management" could be a cookie issue setting or security software caused or Addon issue with the Browser.

more options

I did not download the file, I created it from scratch. And there's only those two lines.

How do I get rid of that "Your browser is being managed by your organization."  ?

more options
  1. It should be working. Double-check the file name. Is it userChrome.css? Or userChrome.css.txt?
  2. Please read [/questions/1409711]
more options

1. Checked this, file name is UserChrome.css

2. Thanks for the link, got rid of the "Your browser is being managed by your organization." message.

more options

userChrome.css still works here, as does userContent.css. I don't have either of the lines you mention but I do have a line setting the background colour of the urlbar which you could test, perhaps making it red.

#urlbar-background { background-color: #f00 !important; }