Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Quickbooks Online not accessible through Firefox.

  • 6 replies
  • 6 have this problem
  • 28 views
  • Last reply by cor-el

more options

Multiple attempts throughout the day. Finally tried Google and no problems. Have others shared this problem? Any thoughts or suggestions?

Multiple attempts throughout the day. Finally tried Google and no problems. Have others shared this problem? Any thoughts or suggestions?

All Replies (6)

more options

There's not much info or screenshot of issues for anyone reading to know what happened or what the issue was?

more options

Cannot log in to Quick Books Online using Firefox. Tried clearing cache, cookies, etc. standard fixes for this sort of stuff. Quick Books is suggesting using another browser, but I've been using QBO on Firefox for years. What happened?

more options

I haven't been able to login to QBO for a week now. Have to use Chrome, which I don't like. What happened? I have used QBO with Firefox for years.

more options

Still can't use QBO with Firefox. Please.....don't make me have to use Chrome! I'm begging you! ;)

more options

Same issue as mentioned above. Using another browser is not a solution. I choose Firefox for its security.

My first login of the day takes me to the screenshot of the spinning dots. Goes forever. I close down the browser and reopen. If I am lucky, the 2nd attempt takes me to this error code. Today I tried to 'solve' the problem and have still not been able to login.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window