Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Subject line not display in Thunderbird inbox

  • 16 replies
  • 1 has this problem
  • 81 views
  • Last reply by calsea

more options

The subject line in my Thunderbird inbox stopped displaying. I tried restoring columns, cloning columns, and deleting session.json and xulstore.json, then restarting Thunderbird, and restarting my PC. I'm running Windows 11, 22H2. I'll appreciate any help given ~ calsea ~

The subject line in my Thunderbird inbox stopped displaying. I tried restoring columns, cloning columns, and deleting session.json and xulstore.json, then restarting Thunderbird, and restarting my PC. I'm running Windows 11, 22H2. I'll appreciate any help given ~ calsea ~

Chosen solution

The ones with zero size contain no messages. If you copy the Inbox mbox 33857 KB to Mail/Local Folders, it should be readable when TB restarts.

If the mbox 54249 KB is not displaying properly in TB, delete the mbox and Inbox.msf with TB closed, and it will be rebuilt when TB restarts, and should show the Subject column.

Read this answer in context 👍 0

All Replies (16)

more options

Does this happen only when Unified is selected under View/Folders?

more options

Thanks for asking. Unified is not selected. I have many folders, and the inbox folder is the only one not displaying the subject

more options

Select a folder that shows the Subject, then click the icon at the right end of the column buttons, Apply columns to, Folder..., select the Inbox. If that doesn't help, try selecting Properties from the Inbox context menu, then Repair Folder.

more options

Thanks, Sfhowes ~ unfortunately, neither solution works. Do you think I need to install Thunderbird and then reinstall? If so, will I lose data?

more options

Reinstalling won't help, as it doesn't affect the data in the separate, profile folder.

If this is an IMAP Inbox, try this: Help/More Troubleshooting, Profile Folder, Open Folder, close TB, open the ImapMail/<imapservername> folder, delete 2 mbox and index files, Inbox and Inbox.msf, then restart TB, which will automatically create a new Inbox on first connection with the mail server.

more options

Maybe I'm being dumb, but Idon't understand. I've added an image for my imap folder. I don't see the Inbox or index.mfs here. I opened the imap.gmail folder and found Inbox and an inbox.mfs files. The inbox file is 54K and suspect that contains data. I opened imap.gmail-1 folder and found an inbox.mfs file. I opened imap.gmail-2 and found another inbox.mfs file. I also found inbox.mfs in the google.gmail folders.

I don't know which to delete.

I have two gmail accounts. One is personal and the other is associated with a google group.

more options

Your ImapMail folder contains only two subfolders dated 2022, so I think <imap.gmail.com> contains the relevant files. You can also find out which account is using which subfolder by selecting Server Settings for the account in Account Settings and looking at the Local Directory in the right pane.

more options

Oh dear. (I'm being polite :) The account is set up as a POP not a imap. I think at one time it was a imap...but ..the local directory is C:\Users\Calsea\AppData\Roaming\Thunderbird\Profiles\sgimithz.default\Mail\pop.gmail-2.com which contains an inbox (9/9/15) and an inbox.msf 912/17/22).

I need to delete these two files?

more options

No, don't delete the files if it's a POP account. Try this: with TB closed, copy the Inbox mbox file from Mail\pop.gmail-2.com to Mail\Local Folders, then restart TB and see if the folder appears correctly under Local Folders in the Folder Pane.

more options

I copied the inbox.msf file to the local folders and restarted Thunderbird. Still no subject display.

more options

Copy the mbox file, the one without a file extension. The .msf index file is rebuilt automatically when TB restarts.

more options

I don't see a mbox in any of the Mail folders. Do you mean Inbox with no extension?

more options

Yes, Inbox with no extension, with 'File' Type in File Explorer. The mbox files are the largest files in the folder (see picture).

more options

Mail\pop.gmail-2.com\inbox has 0KB as do the other inboxes in other folders, except: Mail\pop.gmail.com\inbox has 33857 KB but date modified is 6/18/2011

ImapMail\imap.gmail.com\inbox has 54249 KB with a date modified 12/1/2022 I've attached the server setting window in case that'll help

I really appreciate your patience in working with me. I know it can hard when you aren't seeing what I see and am doing.

more options

Chosen Solution

The ones with zero size contain no messages. If you copy the Inbox mbox 33857 KB to Mail/Local Folders, it should be readable when TB restarts.

If the mbox 54249 KB is not displaying properly in TB, delete the mbox and Inbox.msf with TB closed, and it will be rebuilt when TB restarts, and should show the Subject column.

more options

Good day ~ \

I did as you suggested and still no luck. But...

I then again tried applying the column settings from another folder, and it worked. I must have screwed up the first couple of times I tried it. I feel horrible wasting your time on this. You may or may not feel better I have learned information about TB that I did not know. Always a good thing.

Again, I truly appreciate your patience! I wish you and yours a happy holiday season. May the new year bring you rediscovery and renewal ~

Carol ~