Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Link doesn't display in Firefox but displays properly in other browsers.

  • 5 replies
  • 0 have this problem
  • 5 views
  • Last reply by cor-el

more options

Having an issue with a link not displaying in Firefox 105.0.5 (64-bit).

It’s the “read more” link on this url: https://www.swansonvitamins.com/p/swanson-premium-triple-magnesium-complex-400-mg-300-caps

The “read me” link doesn’t display in Firefox but displays properly using:

      Brave (1.45.123)
      Chrome (107.0.5307.107) (Hate Google)
      Internet Explorer 11 (11.0.170)
      Microsoft Edge (107.1418.35)

I searched “firefox some links don't display” and tried the solutions I found to no avail.

Tried these:

      Turned VPN off.
      Started in Troubleshoot Mode.
      Removed cookies and site data for this site.
      Turned Enhanced Tracking off for this site.

With all of these settings (at once, not one at a time) and closing and reopening Firefox (in Troubleshoot Mode) the “read more” link still doesn’t display.

Attached image showing how the link displays in Brave and how it doesn't display in Firefox.

Thank you.

Having an issue with a link not displaying in Firefox 105.0.5 (64-bit). It’s the “read more” link on this url: https://www.swansonvitamins.com/p/swanson-premium-triple-magnesium-complex-400-mg-300-caps The “read me” link doesn’t display in Firefox but displays properly using: Brave (1.45.123) Chrome (107.0.5307.107) (Hate Google) Internet Explorer 11 (11.0.170) Microsoft Edge (107.1418.35) I searched “firefox some links don't display” and tried the solutions I found to no avail. Tried these: Turned VPN off. Started in Troubleshoot Mode. Removed cookies and site data for this site. Turned Enhanced Tracking off for this site. With all of these settings (at once, not one at a time) and closing and reopening Firefox (in Troubleshoot Mode) the “read more” link still doesn’t display. Attached image showing how the link displays in Brave and how it doesn't display in Firefox. Thank you.
Attached screenshots

All Replies (5)

more options

Thanks for the screenshots... Wish more users would do that.  ;-)) Just as a test, can you download another version of Firefox and make sure to install in a different directory than the current install.

Helpful?

more options

Also, where did you get Firefox from? If you have no data in your current install of Firefox, you can try the Refresh option. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Modified by jonzn4SUSE

Helpful?

more options

One thing I notice about your screenshot is that the content is more tightly spaced. For example, there isn't any blank area below the logo at the upper left. Also, the text at the left of the green bar wrapped to a new line. This reminds me of problems that could be caused by setting a minimum font size larger than 10. Could you check:

Open the Settings page using either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter to load it

Scroll down to the Fonts section and click the "Advanced..." button. For the "Latin" character set, clear the minimum font size setting and click OK.

In the Zoom section below that row, make sure you've got Firefox set to proportional zoom (no check in the box for Zoom text only):

Does that fix the page layout? If text is now too small, try using zoom (hold down Ctrl and tap the + button).

Helpful?

more options

Good catch! The font does look tight. ;-)

Helpful?

more options

Do you see this button in the Inspector ?


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.