Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox showing as not the default browser in Lubuntu, even though it is set as the default browser in the system.

  • 3 replies
  • 0 have this problem
  • 6 views
  • Last reply by jonzn4SUSE

more options

Please fix it if you can.

Please fix it if you can.

All Replies (3)

more options

This issue is with your distro version. What happens if you download Firefox from Mozilla and set it as default? https://www.mozilla.org/en-US/firefox/all/#product-desktop-release Just download, unzip, and run firefox-bin from the folder.

Helpful?

more options

Will I need to uninstall firefox beforehand? The one installed by default on Lubuntu is a snap.

Helpful?

more options

No, you will not need to uninstall. I run multiple versions on all laptops from the Downloads folder. see screenshot

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.