Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 106.0.1 doesn't recognize system default app

  • 2 replies
  • 0 have this problem
  • 3 views
  • Last reply by jonzn4SUSE

more options

I'm using Ubuntu Mate 22.04, Firefox 106.0.1 SNAP install. I setted to TRUE the option browser.download.start_downloads_in_tmp_dir , when I open a document from a web page like .docx or .xlsx I can see the window that ask me how to manage the file, if I choice to open it (not download), Firefox present the option "Open with System Handler (default)" but nothing happens. Please remember that if I download the file and double click it, Libreoffice is called and opens the file. If I select "Choose other" Firefox opens an empty list of apps. In settings I can't change the option "System default". How can I fix this?

I'm using Ubuntu Mate 22.04, Firefox 106.0.1 SNAP install. I setted to TRUE the option browser.download.start_downloads_in_tmp_dir , when I open a document from a web page like .docx or .xlsx I can see the window that ask me how to manage the file, if I choice to open it (not download), Firefox present the option "Open with System Handler (default)" but nothing happens. Please remember that if I download the file and double click it, Libreoffice is called and opens the file. If I select "Choose other" Firefox opens an empty list of apps. In settings I can't change the option "System default". How can I fix this?
Attached screenshots

Modified by luca.dgh

All Replies (2)

more options

Ok, I reinstalled Firefox from Launchpad PPA and it's working properly now.

Helpful?

more options

Mark it as resolved and have a nice day.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.