Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hotkeys messed up or broken

  • 6 replies
  • 1 has this problem
  • 8 views
  • Last reply by Apollo

more options

I've lost the ability to use site-based hotkey shortcuts. For example, if I pull up Google Docs, if I type a statement and try to bolden the text with Ctrl + B, I get the Bookmark sidebar instead. Ctrl + I for italics? Instead I get page info. Ctrl + U to underline? Instead I get a wall of coding. This issue is a consistent thing on all websites, for a variety of hotkey commands.

I can't find where I can change, or turn off hotkeys in general, the last three hours of scouring the internet, including the FF forums, have been no help. I can't tell if this is a setting I can't find, I change with an update, but whatever it is, it needs to be reverted. I'd very much prefer not to switch browsers over an issue that should be a changeable setting.

I've lost the ability to use site-based hotkey shortcuts. For example, if I pull up Google Docs, if I type a statement and try to bolden the text with Ctrl + B, I get the Bookmark sidebar instead. Ctrl + I for italics? Instead I get page info. Ctrl + U to underline? Instead I get a wall of coding. This issue is a consistent thing on all websites, for a variety of hotkey commands. I can't find where I can change, or turn off hotkeys in general, the last three hours of scouring the internet, including the FF forums, have been no help. I can't tell if this is a setting I can't find, I change with an update, but whatever it is, it needs to be reverted. I'd very much prefer not to switch browsers over an issue that ''should'' be a changeable setting.

Chosen solution

Usually sites have permission to override built-in keyboard shortcuts by default. As Terry mentioned, you can check it by calling up Page Info (Ctrl+i) while on the problem site:

Read this answer in context 👍 2

All Replies (6)

more options

You could try this. I've never needed it so I can't confirm that it will resolve your issue. When on the site, open the Page Info window and on the Permissions tab configure Override keyboard shortcuts.

If that doesn't work, you may have to create an autoconfig file.

https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig https://support.mozilla.org/questions/1367908

Helpful?

more options

Chosen Solution

Usually sites have permission to override built-in keyboard shortcuts by default. As Terry mentioned, you can check it by calling up Page Info (Ctrl+i) while on the problem site:

Helpful?

more options

Did you look in "Tools -> Page Info -> Permissions" for "Override keyboard shortcuts" ?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

jscher2000 - Support Volunteer said

Usually sites have permission to override built-in keyboard shortcuts by default. As Terry mentioned, you can check it by calling up Page Info (Ctrl+i) while on the problem site:

Thank you all so much, had no idea to look in Page Info, just saved me a lot of headache

Helpful?

more options

If your global default is Block and you want to change it back to Allow, this is where to find it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste permissions.default.shortcuts and pause while the list is filtered

(3) Click the Reset button (left-arching arrow) at the right end of the row to restore the default value of 0 (that's a zero), or you can double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

Helpful?

more options

Also really good to know, I'll have to mark that down. I downgraded the FF version and then reupgraded during the process, and that also seemed to help. But I can't say if that value was set to 1 or not before reinstalling the update.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.