Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loading some pages but not others?

more options

Internet is fine, other apps and browsers load fine. Mozilla support pages load fine, I'm sending this post through the affected Firefox. But every other page I try to load hangs endlessly. Youtube, FB, DuckDuckGo, reddit, just standalone images, literally nothing else seems to load.

I'd installed a mod loader for a game earlier that gave BitDefender a conniption fit I guess because of the way the loader injected code, and BD insisted on doing a "malware clean" on reboot after I told it not to. I suspect BD must have deleted something or changed permissions, but I can't find anything in its app that would undo or provide exceptions etc.

Is there any way to refresh/troubleshoot without having do a full reinstall? (or else an easier way to do a reinstall that's less of a hassle?) I've already rebooted my PC, restarted Firefox a couple times, emptied the cache and cookies, and tried to connect with no proxy, none so far have worked.

(Windows 10, Firefox v 103.0.2)

Internet is fine, other apps and browsers load fine. Mozilla support pages load fine, I'm sending this post through the affected Firefox. But every other page I try to load hangs endlessly. Youtube, FB, DuckDuckGo, reddit, just standalone images, literally nothing else seems to load. I'd installed a mod loader for a game earlier that gave BitDefender a conniption fit I guess because of the way the loader injected code, and BD insisted on doing a "malware clean" on reboot after I told it not to. I suspect BD must have deleted something or changed permissions, but I can't find anything in its app that would undo or provide exceptions etc. Is there any way to refresh/troubleshoot without having do a full reinstall? (or else an easier way to do a reinstall that's less of a hassle?) I've already rebooted my PC, restarted Firefox a couple times, emptied the cache and cookies, and tried to connect with no proxy, none so far have worked. (Windows 10, Firefox v 103.0.2)

All Replies (1)

more options

Update: I should mention I've already done a virus scan and came up clean.

I figured out how to launch Firefox in "troubleshoot mode", and now everything loads fine again. No idea what changed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.