Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Delete form input history

more options

I'm a hobby-programmer not trained. My doc is local php file, saving calendar events to text files, run on localhost. The field in question is a line number on my calendar. Javascript uses that number to load another input with the calendar entry so I can confirm that it's the correct line before submitting it to PHP for deletion. I have unchecked 'Remember search and form history', ran 3 cleaners, restarted the computer and the data is (correctly) not displayed. But it is not deleted. When I rechecked 'Remember search and form history' the old input data comes back. If I change id, field name, javascript function name and variable names the history disappears but when I restore those names, the history is back. I want to know why that input can't be permanently deleted. Windows 10, Firefox 103.0.2 (64-bit)

I'm a hobby-programmer not trained. My doc is local php file, saving calendar events to text files, run on localhost. The field in question is a line number on my calendar. Javascript uses that number to load another input with the calendar entry so I can confirm that it's the correct line before submitting it to PHP for deletion. I have unchecked 'Remember search and form history', ran 3 cleaners, restarted the computer and the data is (correctly) not displayed. But it is not deleted. When I rechecked 'Remember search and form history' the old input data comes back. If I change id, field name, javascript function name and variable names the history disappears but when I restore those names, the history is back. I want to know why that input can't be permanently deleted. Windows 10, Firefox 103.0.2 (64-bit)

Chosen solution

bob9111 said

I have unchecked 'Remember search and form history', ran 3 cleaners, restarted the computer and the data is (correctly) not displayed. But it is not deleted. When I rechecked 'Remember search and form history' the old input data comes back.

Firefox has a method to bulk clean form history but it's in the History section of the page (or press Ctrl+Shift+Delete). In the dialog make sure to deselect everything else except Form & search history to avoid unwanted data loss:

BUT FIRST:

If you don't want to bulk clear this data for ALL sites, you could test whether adding autocomplete="false" to your input resolves the issue: https://developer.mozilla.org/docs/Web/HTML/Attributes/autocomplete

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

bob9111 said

I have unchecked 'Remember search and form history', ran 3 cleaners, restarted the computer and the data is (correctly) not displayed. But it is not deleted. When I rechecked 'Remember search and form history' the old input data comes back.

Firefox has a method to bulk clean form history but it's in the History section of the page (or press Ctrl+Shift+Delete). In the dialog make sure to deselect everything else except Form & search history to avoid unwanted data loss:

BUT FIRST:

If you don't want to bulk clear this data for ALL sites, you could test whether adding autocomplete="false" to your input resolves the issue: https://developer.mozilla.org/docs/Web/HTML/Attributes/autocomplete

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.