Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

outlook.com access

  • 8 replies
  • 0 have this problem
  • 12 views
  • Last reply by azutkempton

more options

I canNOT access outlook.com (using Mac Monterey) - it was working a couple days ago and now all I get is a blank screen. I can access it using Chrome so I'm thinking this is a Firefox browser issue. I'd REALLY like to continue using Firefox but need to access it on the same browser I've been using.

HELP!!

THANK YOU!

I canNOT access outlook.com (using Mac Monterey) - it was working a couple days ago and now all I get is a blank screen. I can access it using Chrome so I'm thinking this is a Firefox browser issue. I'd REALLY like to continue using Firefox but need to access it on the same browser I've been using. HELP!! THANK YOU!

Chosen solution

Hi azutkempton, I'm on Monterey with Firefox 103, and outlook loads fine here.

Try this: 1. Go to History > Show All History 2. Right-click on outlook.com and choose Forget about this Site.

NOTE: You will need to log into outlook again.

Read this answer in context 👍 0

All Replies (8)

more options

Can you post a full browser screenshot showing what you get? Let test my mac 10.13.6. Did you try Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Did you clear the browser cache? https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Modified by jonzn4SUSE

Helpful?

more options

It works for me. see screenshot

Helpful?

more options

I will try your other suggestions....as requested, here is a screenshot of what my Outlook.com page looks like on Firefox.

THANK YOU for your suggestions and help.

Helpful?

more options

....forgot to add the screenshot - see attached file.

Helpful?

more options

Problem still exists in 'Troubleshoot' mode.

THANK YOU for the suggestions, I'll read up on those and try them...

To jonzn4SUSE: Thank you for that scrrenshot but it appears you are using High Sierra and I am using Monterey. Would that make a difference? .

Helpful?

more options

You can try this option, but make sure you have your password. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions The different OS is not the issue. Your screenshot is soooo widdle!  ;-)

Helpful?

more options

Chosen Solution

Hi azutkempton, I'm on Monterey with Firefox 103, and outlook loads fine here.

Try this: 1. Go to History > Show All History 2. Right-click on outlook.com and choose Forget about this Site.

NOTE: You will need to log into outlook again.

Helpful?

more options

That worked....THANK YOU, THANK YOU!!!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.