Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Selecting to open a file inside browser with Acrobat now always results in file being downloaded too.

  • 4 replies
  • 0 have this problem
  • 14 views
  • Last reply by Dick39

more options

I have the option set to always ask me if I want to open a pdf with browser, acrobat, or to download. I usually select open with Acrobat and, for the last few months, I have been getting an unwanted download as well. I found in the help articles that this is now the default action. For me, it usually means that at the end of a session i have to go to my desktop (my optioned destination for downloads) and clean it up by deleting every file I have looked at.

I recommend that you make that functionality optional. I just want to view the vast majority of things I open. For the few that I might want to download after viewing them, i would prefer to take a proactive step to download them after I have reviewed them.

I have the option set to always ask me if I want to open a pdf with browser, acrobat, or to download. I usually select open with Acrobat and, for the last few months, I have been getting an unwanted download as well. I found in the help articles that this is now the default action. For me, it usually means that at the end of a session i have to go to my desktop (my optioned destination for downloads) and clean it up by deleting every file I have looked at. I recommend that you make that functionality optional. I just want to view the vast majority of things I open. For the few that I might want to download after viewing them, i would prefer to take a proactive step to download them after I have reviewed them.

Chosen solution

You can possibly set this pref to true on the about:config page to make Firefox use the temp folder.

  • about:config => browser.download.start_downloads_in_tmp_dir = true

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

See also:

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

You can possibly set this pref to true on the about:config page to make Firefox use the temp folder.

  • about:config => browser.download.start_downloads_in_tmp_dir = true

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

See also:

Modified by cor-el

Helpful?

more options

Thank you!

Simple to do and seems to provide exactly the functionality I want.

By the way, and showing my lack of understanding, but is the temp dir to which the file is being sent the OS temp dir or something inside Firefox?

Helpful?

more options

It is the OS temp directory as set via the TMP and TEMP environment variables.

Helpful?

more options

Thanks yet again.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.