Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon Seller Central

  • 3 replies
  • 1 has this problem
  • 17 views
  • Last reply by trina2

more options

Hi all,

since the last firefox update I am not able to visit the german Amazon Seller Central website anymore. I have no knowlegde in how to solve this issue and that is why I am asking for your support.

The link to the website is: https://sellercentral.amazon.de/ Whenever I want to visit the site, I get the error "HTTP Status 400 – Bad Request" (see attached image).

I already checked with amazon themselves, but they said the issue lies within my computer. My IT department said the issue is related to the browser most likely; and indeed, with Microsoft Edge for example, I am able to open the website.

Does anyone know this error and even better knows how to solve the problem?

Thanks in advance!

Hi all, since the last firefox update I am not able to visit the german Amazon Seller Central website anymore. I have no knowlegde in how to solve this issue and that is why I am asking for your support. The link to the website is: https://sellercentral.amazon.de/ Whenever I want to visit the site, I get the error "HTTP Status 400 – Bad Request" (see attached image). I already checked with amazon themselves, but they said the issue lies within my computer. My IT department said the issue is related to the browser most likely; and indeed, with Microsoft Edge for example, I am able to open the website. Does anyone know this error and even better knows how to solve the problem? Thanks in advance!
Attached screenshots

All Replies (3)

more options

Did you try in Private Mode and what happens? Usually that 400 error comes from the server and sometimes Addons or A/V is blocking cookies from loading giving bad login. But most times it's a Server that is down or not working that gives that error because the link doesn't work.

Helpful?

more options

The link provided works fine. Try clearing cookies & site data for that site - Visit the site. Click on the padlock icon at the left end of the address bar. Select Clear Cookies and Site Data. In the dialog that opens, select Remove. Refresh the page...

Helpful?

more options

This problem "HTTP Status 400 – Bad Request" error has been happening for myself and many other Amazon Sellers. It started for me when I updated to the latest 104.0.2 on September 6th. It is occurring in the US on https://sellercentral.amazon.com. It occurs all throughout the day. I am able to clear cache and cookies, but withing a couple hours, I have to clear them again. It is very frustrating because then I have to log in many times a day.

Thanks for looking into this!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.