Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with saving webpages with .com etc. in title

  • 10 replies
  • 2 have this problem
  • 13 views
  • Last reply by nabaC

more options

Hello, in last few days I notice that when you try to save web page that has title ending with .com or anything like that saved file has .com extension instead of htm. I often use this option and I'm sure it must be one of the latest updates that started to cause that. Any chance it gonna get fixed and Firefox start adding .htm after .com?

For example try saving page https://www.naturalnews.com/ its title is "Natural Health News and Scientific Discoveries - NaturalNews.com" and saved file has .com extension. I need to fix it everytime and add .htm manually.

Martin

Hello, in last few days I notice that when you try to save web page that has title ending with .com or anything like that saved file has .com extension instead of htm. I often use this option and I'm sure it must be one of the latest updates that started to cause that. Any chance it gonna get fixed and Firefox start adding .htm after .com? For example try saving page https://www.naturalnews.com/ its title is "Natural Health News and Scientific Discoveries - NaturalNews.com" and saved file has .com extension. I need to fix it everytime and add .htm manually. Martin

All Replies (10)

more options

When I go to save as I get this:

Natural Health News and Scientific Discoveries - NaturalNews Web Page, Complete

This is what I see in the save option. What exactly are you seeing?

Modified by Dropa

Helpful?

more options

Dropa said

When I go to save as I get this: Natural Health News and Scientific Discoveries - NaturalNews Web Page, Complete This is what I see in the save option. What exactly are you seeing?

When I save the page, no matter if by ctrl+s or rightclick on page and "save as", I get this (pic uploaded). When I switch between complete site and html only indeed extension is changed to .htm, but originally it tries to save with .com. It happens both on Windows 10 and 7, just tried.

Helpful?

more options

Today's Firefox 102.0.1 update has a fix for a problem creating desktop shortcuts with .com at the end of the title. I wonder whether that will help in the Save Page As case?

https://www.mozilla.org/firefox/102.0.1/releasenotes/

Helpful?

more options

jscher2000 - Support Volunteer said

Today's Firefox 102.0.1 update has a fix for a problem creating desktop shortcuts with .com at the end of the title. I wonder whether that will help in the Save Page As case? https://www.mozilla.org/firefox/102.0.1/releasenotes/

I just updated browser to the latest relase, unfortunately my problem remains. Hope it's already noticed and gonna be fixed.

Same happens with other extensions of course. For example when trying to save https://wizaz.pl/forum/ I get file with .pl extension as default because title ends with that: "Forum - dyskusje, opinie, porady - Wizaz.pl". :P

Helpful?

more options

Did you disable all Addons and see if they aren't affecting the saving option?

Helpful?

more options

Dropa said

Did you disable all Addons and see if they aren't affecting the saving option?

Yup, I'm using 2 addons - Video DownloadHelper and uBlock Origin, it happens with them turned on and off, on both systems - W10 and W7.

Helpful?

more options

Looks like shortcuts were fixed but not Save Page As. I don't know whether that was reported because it probably would have gotten fixed at the same time.

This is a workaround that might be faster than renaming: double-switch the format in the drop-down. For example, if your format is Web page, complete, change to one of the other two, then change back. This triggers Firefox to add the proper extension.

Helpful?

more options

jscher2000 - Support Volunteer said

Looks like shortcuts were fixed but not Save Page As. I don't know whether that was reported because it probably would have gotten fixed at the same time. This is a workaround that might be faster than renaming: double-switch the format in the drop-down. For example, if your format is Web page, complete, change to one of the other two, then change back. This triggers Firefox to add the proper extension.

Switching format works like that, it's also possible to just remove said extension and without .com or .pl in the end Firefox adds .htm automaticly when web page is saved. Let's hope they fix it next time. :)

Helpful?

more options

I filed a bug. Hopefully it will get triaged in the next couple of days.

https://bugzilla.mozilla.org/show_bug.cgi?id=1778597

See also: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Helpful?

more options

jscher2000 - Support Volunteer said

I filed a bug. Hopefully it will get triaged in the next couple of days. https://bugzilla.mozilla.org/show_bug.cgi?id=1778597 See also: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Thanks for highlighting this bug to ff team. Surely they gonna fix it sooner or later now. :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.