Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird 102.0 corrupts emails

  • 74 replies
  • 13 have this problem
  • 235 views
  • Last reply by Matt

more options

I upgraded to TB 102.0 today. After I checked my settings and updated my plugins, it seemed to be working fine. However, later in the day I noticed a message that TB was downloading about 880 messages in my main inbox. Of course, there are not nearly that many new messages. I searched and did not notice any new emails in the listing. However, I found that two recent messages had been corrupted in some way. I enclosed an image. When I open the message, there is not even the normal header with the different choices. There is just what appears to be a bunch of information that has been mushed together in place of this email. I found two emails like that. I right clicked on the two, and deleted the corrupted messages. Then I compacted files. For a moment, things seemed OK. Some other emails near those that would not display worked again. However, shortly after I did another compact folders, I got the same message -- downloading the same 880 emails. Now I have two new messages corrupted.

Please help! I have no idea how to stop this corruption. This account is hosted on Google Workspace. I have it set to sync only the last 90 days of messages.

I upgraded to TB 102.0 today. After I checked my settings and updated my plugins, it seemed to be working fine. However, later in the day I noticed a message that TB was downloading about 880 messages in my main inbox. Of course, there are not nearly that many new messages. I searched and did not notice any new emails in the listing. However, I found that two recent messages had been corrupted in some way. I enclosed an image. When I open the message, there is not even the normal header with the different choices. There is just what appears to be a bunch of information that has been mushed together in place of this email. I found two emails like that. I right clicked on the two, and deleted the corrupted messages. Then I compacted files. For a moment, things seemed OK. Some other emails near those that would not display worked again. However, shortly after I did another compact folders, I got the same message -- downloading the same 880 emails. Now I have two new messages corrupted. Please help! I have no idea how to stop this corruption. This account is hosted on Google Workspace. I have it set to sync only the last 90 days of messages.
Attached screenshots

All Replies (20)

more options

I brought the files back from the recycle bin. That TB file is now as it was. Still with missing messages. I checked other files/folders and still missing messages.

more options

And just to bring this back to the original question, my messages are doing the same thing as MarkL's. All garbled up and totally unrelated to the sender's message. So not able to read anything. Just a lot of useless stuff. i.e. Hit the delete button. ? 800 times - well, no, just highlight them and delete. But that isn't always best. It is better to view each one before deleting. There might be some of the messages that should Not be deleted. IMHO someone at TB ought to be looking into a solution that don't require a procedure that is totally difficult for a layman. Those of us just using TB to read and retain messages should not have to be computer experts. What about the people with no skills for PC? The average person? I'm sorry but the "back up" procedure is ridiculous.

more options

Wayne knows a lot more than I do. However, if his suggestion failed, let's go back to the address books.

Select the tab labeled Address Book to bring up the address book page. I assume you will see what you showed in the screen shot earlier. This is different than what I am seeing. Perhaps TB 102 has a different layout. Based on how TB usually works, I can suggest two things. First, right click in the blank space just to the right of the tab labeled "Import." That may give you an option to customize the ribbon. If so, select that, and I suspect there will be an export tab that you can drag up to the ribbon. If so, you can use that to export the address book. If that does not work, try right clicking on the "Personal Address Book" label, and see if it gives you an export option. You might also try just clicking on the 3 dots just to the right of the Personal Address book label to see if it provides options for export.

The extra "Export" tab next to the Inbox and Address Book tabs is apparently a new feature of TB 102 that exports the entire profile. Perhaps something in the corruption of your profile causes this to fail.

more options

OK. I cannot export the "all address books", but apparently can export each book by itself. I did one, and it saves as a csv spreadsheet. I now assume they all can be saved as a csv. So where do I save them? The initial option was the default file I had saved before, from this current 102.0.3 version. So, that would mean each export file would be a new file in that default. (FYI the default is listed as: "C:\Users\MorganF\AppData\Roaming\Thunderbird\Profiles\09qrcdzk.default-release") So is the right place for the csv's?

more options

Yes, you will need to save the address books one at a time. I would save them not in the Thunderbird profile -- perhaps in your documents folder. Maybe create a folder in Documents for TB backups. Saving as csv file should work. You might also want to save each as a .vcf file. That is a more universal format that TB 102 is supposed to accept. Not really necessary; I am just being safe.

When you are sure you have them all saved, you can try creating the new profile with all your accounts. By creating a new profile, the old profile will still be there in case you need to go back to it sometime. Let me know how you make out.

more options

Just FYI. I could find no way to save a csv as a vcf. Vcf is not shown anywhere. OK. Now how do I create a "new profile with all your accounts"? I do have a separate file on my desktop marked "TB" and with the new csv's copied to that file, there is now 103 items in the file marked "TB". Including (apldrxiy.default, crashes, datareporting and many more. And zip files for TB/from installing.) So, I don't know what should be included in "my new profile". (FYI the folders are dated from 2004 to 2022. So I don't even know what that all means.)

more options

No. You won't use any of the saved files. You need to click on the 3 bars icon in the upper right. Under that, select Help>More Troubleshooting Information. Near the bottom of the first large table of information that appears, click on the about:profiles link. This will open a page showing all your known profiles. At the top of the page is a box to create a new profile. Click on that box. This will take you to where you were when you first configured Thunderbird, as if you are starting fresh. In essence, you will now go through the same process you used to create all your email accounts when you first set up TB. (TB does make it easier now by prefilling much of the information.) This should recreate your profile, and each new account should sync all the emails that existed before from the servers. This could take a little while depending on how many emails you have. You should see all your emails again. Then you can import the address books you saved. The address books will probably import as separate from the Personal Address Book. However, you can probably copy and paste the contacts from an imported one into the standard Personal Address Book if you want.

more options

Here's where I'm at. I now have a separate TB account. Brand new. And also the old one. Now what? Should I continue with the new one, adding all the other email accounts? And if so, will all my messages come with it? Whoops. That new one just disappeared. And the only TB I have is the old one. ???

more options

And now, it also isn't in the same order that it was. The main folders are changed in order. ????

more options

Is there a way for me to change the order of folders? I tried snap and drag, but that don't work. And all I can say is that the new order don't make sense. The old order was also a little weird, but I was able to work with it. This new order is totally wacko!

more options

Oh yeah. It seems all is OK, the address book and all messages have been reinstated. And the messages don't look wacko now. So that might be fixed.

more options

The goal here was to create an entirely new profile for you with all your emails and address books from before, but one that has no corruption. It sounds like you have that. Once you are sure everything is working like you want, you can go back and delete the old corrupted profile. The order of emails and folders might change because of how you did the configuration or new defaults by TB. By the way, you might want to save a copy of the new profile over to your new backup folder just in case something else happens.

There is a TB plugin called Manually Sort Folders that will allow you to change the order of your accounts and how the folders are sorted in the accounts. If you have never used plugins, they are just additional small programs that can be added to TB to provide various features and functions. If you click on the 3 bar menu icon and select AddOns and Themes. You will see any plugins you have now. At the top of the page is a search bar. Search for Manually Sort Folders. Then click Add to Thunderbird, and approve the action. After it completes, you should have a new option -- mine is under the Tools Tab at the top -- to manually sort folders. You can see how to rearrange your accounts and folders.

Let me know how you make out. You should be able to get what you want and be back to just using TB for email. Let me know how things go.

more options

Wow! Finally TB looks normal. ? Well, whatever normal is to me. LOL As for deleting old files. I think I figured it out. Take each file folder, click on properties. See what the created date is. Delete every one except for today's. If this isn't right, I'm doomed. LOL Just let me know if this was the right way? And yes, I saved it in another folder. Also on a flash drive. I save everything in more than one place.

more options

Glad to hear you are back!

I am not sure what you mean by deleting file folders older than those created today. I would be careful about using that as a criteria. If you mean deleting your old profile? Look again in your profile folder for TB, which I believe you said is "C:\Users\MorganF\AppData\Roaming\Thunderbird\Profiles". Before, you had two folders in there. Now you should have a third one with another weird name. That third one is the one you want to copy to your backup locations and keep safe because it is the new profile you just created. Another folder will be the corrupted profile, and the third is probably left over from years ago. I guess you could look at the creation dates for those three folders. If one is created today, and the others are much older, that is a good indication that it is the new profile. To be safe, you can go back into the 3 bar menu, under Help>Additional Troubleshooting Information. Click on about:profiles again. It should have a list of your profiles, with the default one indicated. The default one will be the new one. You could also look under the Tools tab at the top, Account Settings, pick one of your emails and look at Server Settings. Near the bottom it will show the Local Directory. It will be "C:\Users\MorganF\AppData\Roaming\Thunderbird\Profiles\xxxxxxxx\ImapMail\..., where the xxxxxxxx is the current or new profile name. Once your are sure you have the new profile identified and saved, you can delete the others. Perhaps that is what you meant. If so, you figured it out.

I am sorry you got caught with the issues in the new version of Thunderbird. The TB team does a really good job, but, in this case, there were some serious issues with the major new version 102 that were not caught before it was posted to the website. By the way, if you set TB under Preferences to Check for Updates but let me choose whether to install them, TB will notify you of new updates and let you update from there. That process would not have offered you the new 102 version until it had been tested by more people. The TB team did this because they knew a major new version almost always has issues that have not been identified yet. So that is a safer way to update in the future.

more options

Yes. I verified I have the correct profile folder. I now think it's under control. As for future updates, yes I found where I can be notified before updating. I had it set for auto and that's why I was so upset about all this. The update to 102 occurred automatically. That was obviously a wrong thing for TB to do. So now I'm more careful. I will end now with a profound thanks to you, MarkL. I am sure glad it was you that came here and helped me.

more options

I am not sure why TB updated you to version 102 if you had automatic updates. TB was set for automatic updates to only offer updates in the 91.xx series. Version 102 was posted on the website, and clearly said it is a new version that is only available when one manually downloads it from the website and installs it from there. It said it will be offered to all when more people have tested it. I got caught because I did not pay attention. I knew TB had given me a notice of an update. I just went to the website and picked the latest version without reading the release notes or noting that the one I downloaded was not what TB's internal update process was offering, which was 91.11.0. Fortunately, I make backups every day, so I was able to go back to 91.11.0 by restoring my profile from the prior day. I am just glad we could get you going again.

more options

Well, to be honest. It's been a while since this started, so I honestly can't say I was warned. It sounds like I did what you did. Went to the web site and downloaded from that. Not realizing it was 102 as a beta. As I mentioned, this beta stuff is deceiving to laymen. Got me into trouble on another download, that was resolved easier than TB. In that case, I simple uninstalled the beta, installed the previous one and that was that. I tend to save almost everything. And my back up files get large. And then, once in a while, I go in and clean them - by deleting the oldest ones. Leaving the current and the last one. And that's why in this case, when I uninstalled 102 and installed/or tried to install 91.2, that this whole thing fell apart. Because when the download for 91.2 showed up, it warned that it would be deleting all previous data, messages, address book and ALL. So, I was afraid to do that. Hence being on this forum. FYI the other software I had this trouble and was able to resolve easily was Libre Office. When I open it from Start, it shows in the upper right corner an icon that says "update available". And I've learned to ignore it. And wait until they actually send me an email telling me to update/upgrade. That's another annoyance. Upgrade vs update. What the heck! And another bad place is Windows. All this talk about 11. And all the people making all sorts of noise about how bad or good it is. So I'll wait for a year or more so they get some bugs out of it. I strongly suspect that in 2024, I will be ready to install Windows 11. And I won't go into all the other software that has to be updated/upgraded every time I turn around. Some weekly/anti-virus for example. And you can bet your bippies I update that - but that is done auto. Nice too, they tell me when it's updated. Same with auto update/cleaning by Lenovo/my PC's brand. My laptop is another pest. It's a Dell. To update that, I have to go online. No matter how I try to update any other way, it don't. And when online, I have to update each and every one - one at a time. Takes me all day - on the second Wednesday of each month. (The update is on Tuesday, but it won't work for me until Wednesday. Updating everything I can. Dell included. Not just MS. PITA. Sorry I got off topic. Thanks again for your excellent help.

more options

It is not a topic for this forum, but Dell has software called "Dell Update" that will check for and install updates. (Business computers have Dell Command Update and another newer one.) You should find it on the Dell support site for your laptop. I prefer to do manually so I know what is happening when. Also, there is a great newsletter at askwoody.com, a free version and a paid version. This gives regular information on Windows updates, where there are issues, when it is safe to install, and lots of other good information. It has saved me many times, but it is more to read and keep up with.

more options

You are right, sorry I brought up the other situations. But. Now I have a different problem with the new TB 102.0.3. The address book has duplicates of almost everyone in the list. So I deleted all except one. And you know what? They disappeared from the special lists. i.e. I had a list for relative. That list had about 4 or 5 people in it. That list is now blank. Those people are still listed in my Personal address list. But I can't figure out how to get them duplicated in the other file. I simply can not believe that they must be listed twice just so they appear in the other list. It also appears to be a headache to create a list. Not like it was with 91.2 at all. I'll keep on trying, and if you know what I mean and can help. Fine.

more options

OK, I tried this. Went back to import and did that with those csv files. So now I have the special files for relatives. But. There are the duplicates in the personal address book. ? That's a lot of duplicates - and I don't see why. Back with 91.2, I had the names listed once in each file. Not doubled and tripled. Example. I would have a name in PRR, the same name in Railroaders, and if they were related, would be in Relatives. But only once in Personal Address Book. And of course, in All Address Books. The changes made in 102 are not really well thought out. Someone goofed up somewhere.

  1. 1
  2. 2
  3. 3
  4. 4