Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Online banking - Fifth Third Bank

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by WWWIII

more options

This questions has been around awhile and answered a couple of times but I still have the problem even after using all correction methods previously submitted to this question. I can load the Fifth Third Bank site (53.com) but cannot sign on; I get the usual "OOPS" message with the number to call Fifth Third Technical Support. I called their support and the first question they asked is what browser I'm using. After responding that Firefox was my browser, they told me that everyone who uses Firefox is having problems. They contend there is nothing on their end causing the problem and that since users of other browsers were not having problems that the only solution they could offer was to switch to Edge or Chrome. That's ridiculous! What is causing this problem? I do not want to move to either Chrome or Edge!

This questions has been around awhile and answered a couple of times but I still have the problem even after using all correction methods previously submitted to this question. I can load the Fifth Third Bank site (53.com) but cannot sign on; I get the usual "OOPS" message with the number to call Fifth Third Technical Support. I called their support and the first question they asked is what browser I'm using. After responding that Firefox was my browser, they told me that everyone who uses Firefox is having problems. They contend there is nothing on their end causing the problem and that since users of other browsers were not having problems that the only solution they could offer was to switch to Edge or Chrome. That's ridiculous! What is causing this problem? I do not want to move to either Chrome or Edge!

All Replies (3)

more options

Did you try in Private mode with all Addons disabled.

Helpful?

more options

Yes. The first time in private I was able to sign in. I signed out and then tried to sign back in and it wouldn't let me nor has it allowed me in over the next couple of dozen tries during the troubleshooting as answered to this same problem on, I believe last August.

Thanks for taking a look!

Helpful?

more options

These are the troubleshooting tried so far: https://support.mozilla.org/en-US/questions/1355749

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.