Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 99 is not applying the chosen content action for MSMoney OFX files - deosn't matter what action is chosen it just saves

more options

Until the last FF release (99), when I downloaded files from my bank for MSMoney FF would apply the action to use the MS Money import handler. Not anymore. FF will now only save the file. Even if I choose "always ask" it still just saves the file - never asks what to do with it (save or open with). Please fix this. It's worked fine for decades and now doesn't work at all. I tried adding images to show what happens but the ones that show what FF is doing and the FF settings won't upload. Only the banking download page images will upload. They just show that I pick MSMoney as the download format.

Until the last FF release (99), when I downloaded files from my bank for MSMoney FF would apply the action to use the MS Money import handler. Not anymore. FF will now only save the file. Even if I choose "always ask" it still just saves the file - never asks what to do with it (save or open with). Please fix this. It's worked fine for decades and now doesn't work at all. I tried adding images to show what happens but the ones that show what FF is doing and the FF settings won't upload. Only the banking download page images will upload. They just show that I pick MSMoney as the download format.
Attached screenshots

Chosen solution

nvanbeancounter said

Just downloaded again after clicking "always open similar files" and FF just saved the file again. In addition the checkmark for "always open similar files" is gone. Sure wish I could show you my settings but the screen shot won't upload.

It's sensitive -- each time you click it the action is switched between "Use [relevant application]" and "Save file".

Regarding the screenshot, I paste into Windows Paint to save my screenshots before uploading here. Not fancy, but after 20 (?) years, it is still doing the job.

Read this answer in context 👍 0

All Replies (10)

more options

Hmm, is there a different entry for OFX files?

(1) You can try changing the behavior for other file type on the Applications list on the Settings page. This article has the steps: Manage file types and download actions in Firefox

(2) If the file type you want to manage is not listed there in any recognizable way, try this next: open the Downloads list, right-click the file, and choose Always Open Similar Files.

Firefox then should add that file type to the Applications list with a "Use [default application]" action. You can use the steps in the previously mentioned article to change it to an Always Ask action if you prefer that.

(3) If that menu item is missing for these downloads, the site might be misidentifying the file as generic binary content instead of identifying it as a specific type.

This is harder to work around. I can suggest an add-on if you encounter this frequently.

Helpful?

more options

re item #1 I have already reset the way FF is supposed to handle the OFX files to always ask open with C:\Program Files (x86)\Microsoft Money Plus\MNYCoreFiles\mnyimprt.exe open with C:\Program Files (x86)\Microsoft Money Plus\MNYCoreFiles\msmoney.exe FF ignores all and just offers to save in the default download folder.

This worked fine the day before I updated to FF99.

re #2 - I did that as instructed. No new content was added to the list. No OFX files in the list, just MS Money icon with content "open file exchange file" beside it. So it has the correct default app but all it does is save the file.

Helpful?

more options

If the item has a checkmark for "Always Open Similar Files" then when you re-download that file, or download other files sent with the identical Content-Type, then Firefox should auto-open the files.

If that is not working, something is missing, but I'm not sure what it is.

If the files that auto-save do NOT have a checkmark for "Always Open Similar Files" then that server probably identified them differently (different Content-Type).

Helpful?

more options

Just downloaded again after clicking "always open similar files" and FF just saved the file again. In addition the checkmark for "always open similar files" is gone. Sure wish I could show you my settings but the screen shot won't upload.

Helpful?

more options

I just checked the file handler settings again and one of the times I did the "always open similar files" FF crossed and OFX file with a TXT file and put them together with MS Money content. How do I get rid of that content option? I click on the action and it only allows me to assign save or always ask or use other than the MSMoney handler. but the content now reads "open financial exchange file (txt/ofx). I have a 2nd one associated with MSMoney and its content reads "open financial exchange file (application/x-ofx).

Helpful?

more options

These Content-Type indications are coming from the server. Maybe you have downloaded OFX files from two different servers that have a different opinion about how to identify them?

Can you manually assign MS Money to handle the txt/ofx files?

I actually don't think there is a nice way to remove a content-type after it has been saved in the download actions file ("handlers.json"). In extreme cases, you might remove the file and start over with your Applications list, but I'm not sure it is that much of a problem yet?

Helpful?

more options

Chosen Solution

nvanbeancounter said

Just downloaded again after clicking "always open similar files" and FF just saved the file again. In addition the checkmark for "always open similar files" is gone. Sure wish I could show you my settings but the screen shot won't upload.

It's sensitive -- each time you click it the action is switched between "Use [relevant application]" and "Save file".

Regarding the screenshot, I paste into Windows Paint to save my screenshots before uploading here. Not fancy, but after 20 (?) years, it is still doing the job.

Helpful?

more options

I download ofx from the only bank that still exports to MSmoney -Tangerine bank. It worked fine before FF99 update. This time I checked before download to make sure that "always open similar files" was checked. It worked at last. FF ignored the conflated txt/ofx content icon which I had set to "always ask". Thank you for your help.

Helpful?

more options

ps. i tried saving the images to paint instead of another app that produces jpg files. Still won't upload the images that show my settings. the little wheel just keeps circling and below it says "uploading filename"

Helpful?

more options

Hmm, sorry about the image upload. Some people have that problem with most images; I see it about once a week. I'm not sure whether the root cause has been identified.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.