Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pop-up exceptions not working

  • 9 replies
  • 2 have this problem
  • 2 views
  • Last reply by Renaud

more options

Hello,

The pop-up blocker exceptions are not working for some sites which I, of course, use a lot. The sites are listed in the exceptions, but Firefox stubbornly continues to block them. I sincerly consider walking away from Firefox (notwithstanding I love it and being a long term user), because it happens with sites I frequently use on a daily base.

I've looked around but none of the solutions work for me as those articles are rather old.

My version of Firefox: 99.0.1 (64bit) running under Windows 10 Pro

Hoping to find a solution here.

Renaud

Hello, The pop-up blocker exceptions are not working for some sites which I, of course, use a lot. The sites are listed in the exceptions, but Firefox stubbornly continues to block them. I sincerly consider walking away from Firefox (notwithstanding I love it and being a long term user), because it happens with sites I frequently use on a daily base. I've looked around but none of the solutions work for me as those articles are rather old. My version of Firefox: 99.0.1 (64bit) running under Windows 10 Pro Hoping to find a solution here. Renaud

Chosen solution

Hello Fred and Cor-El,

Thank you for your suggestions. I restored my previous profile and changed the following:

- disabled a Facebook extension (I almost never log on to Facebook anyway) - I realised that Firefox was in 'Always use private browsing mode'. So I unchecked this and applied the settings suggested by Cor-El. The two other checkboxes ( remember search and browsing history) left unchecked.

This seems to have solved the problem. :)

Thank you both for helping me out of this!

Regards

Renaud

Read this answer in context 👍 0

All Replies (9)

more options

Is this with all websites/pages, some, a few?


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Hello Fred,

Thank you for answering my post.

I think it is happening for some sites only. Not 100% sure though.

Unfortunately, disabling enhanced tracking and troubleshoot mode did not solve the problem.

Cookies and cache are deleted every time I quit Firefox too. I did not follow the other suggestions (yet) like reinstalling Firefox or creating a new profile.

When I click the message warning me of a blocked pop-up, then choose to "allow for this site" and reload the page, the page appears when clicking the link. But after a restart, the page is blocked again. The site being in the exceptions all the way.

When clicking to check what is blocked, it seems to be google-analytics


Regards

Renaud

Helpful?

more options

Have you tried: Start In Troubleshoot(Safe) Mode ?

Helpful?

more options

Yes, I did indeed try it in Troubleshooting mode.

The odd thing is that, in one of the sites with issues, I can access that page from a menu and not through a link on the page. Using the menu, the page opens with no problem.

Tried another site listed in the exceptions and that does not work either in Troubleshooting/Safe mode.

Regards


Renaud

Helpful?

more options

Helpful?

more options

Hello Fred,

Creating a new profile did solve the problem indeed.

However, it is a new profile. Does that mean I have to carry on with this profile or can I import bookmarks etc. in this new profile? Or can I locate what causes the issue.

This new one has, of course, none of my settings.

Regards

Renaud

Helpful?

more options

Are you clearing the Site Preferences ?

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Site Preferences

  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • clearing "Cookies" via "Clear history when Firefox closes" will remove all cookies including cookies with an allow exception you may want to keep
  • clearing "Cookies" via "Delete cookies and site data when Firefox is closed" honors exceptions and let you keep cookies with a cookie allow exception

Helpful?

more options

Renaud said

Creating a new profile did solve the problem indeed . . .

That means something about the original profile is causing the issue. It could be an add-on or settings.

You can either try to find what is causing the problem. Or we can instruct you on how to Copy some of the files from the old profile to the new.

Helpful?

more options

Chosen Solution

Hello Fred and Cor-El,

Thank you for your suggestions. I restored my previous profile and changed the following:

- disabled a Facebook extension (I almost never log on to Facebook anyway) - I realised that Firefox was in 'Always use private browsing mode'. So I unchecked this and applied the settings suggested by Cor-El. The two other checkboxes ( remember search and browsing history) left unchecked.

This seems to have solved the problem. :)

Thank you both for helping me out of this!

Regards

Renaud

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.