On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox sync server reverse proxy not working

  • 2 replies
  • 1 has this problem
  • 11 views
  • Last reply by firefox1812

more options

I'm self hosting a firefox sync server on unraid. If I set it up on the local network, it works. I use this public address in the docker container http://localhost:5000 and the about:config server as identity.sync.tokenserver.uri = http://localhost:5000/token/1.0/sync/1.5.

Now if I switch to my reverse proxy, I use this public address in the docker container http://firefox.mydomain.com and the about:config server as identity.sync.tokenserver.uri = http://firefox.mydomain.com:5000/token/1.0/sync/1.5. It does not sync. I get an error if I use that url in the browser link. If I make it http://firefox.mydomain.com/token/1.0/sync/1.5 (taking out the port number), my browser displays a json page. But if I remove the port number in the about:config and make it identity.sync.tokenserver.uri = http://firefox.mydomain.com/token/1.0/sync/1.5, it logs me out of the firefox account.

The reverse proxy is passing port 5000 through, so that is why not specifying it returns a valid browser page. The about:config seems to need the port specified to work. Otherwise I'm getting logged off. Is there a workaround to this?

I'm self hosting a firefox sync server on unraid. If I set it up on the local network, it works. I use this public address in the docker container http://localhost:5000 and the about:config server as identity.sync.tokenserver.uri = http://localhost:5000/token/1.0/sync/1.5. Now if I switch to my reverse proxy, I use this public address in the docker container http://firefox.mydomain.com and the about:config server as identity.sync.tokenserver.uri = http://firefox.mydomain.com:5000/token/1.0/sync/1.5. It does not sync. I get an error if I use that url in the browser link. If I make it http://firefox.mydomain.com/token/1.0/sync/1.5 (taking out the port number), my browser displays a json page. But if I remove the port number in the about:config and make it identity.sync.tokenserver.uri = http://firefox.mydomain.com/token/1.0/sync/1.5, it logs me out of the firefox account. The reverse proxy is passing port 5000 through, so that is why not specifying it returns a valid browser page. The about:config seems to need the port specified to work. Otherwise I'm getting logged off. Is there a workaround to this?

All Replies (2)

more options

Did you read this yet.

Firefox Sync https://support.mozilla.org/en-US/products/firefox/sync

Helpful?

more options

This does not apply to my self-hosted sync server. The problem is it works on my local network but will not work once a public url is used. I can access the public url's in my browser without issue when not port is specified as my reverse proxy forwards port 5000.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.