Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Print" no longer works from a message edit ("Write") window

  • No replies
  • 1 has this problem
  • 1 view
more options

In Thunderbird 91.8.0 (64-bit) on Mac-OS Monterey M1

I often will "Edit Message as New" in order to print an email message with no headers.

Now when in a Message Edit window, the "print" command does nothing.

Also the "Print" icon, available on the edit window toolbar, does nothing.

I have updated & restarted T-Bird, and restarted my Mac. Not sure when the problem started.

Is there a preference that should be enabled?

EDIT: Found the problem -- I had set, using Config Editor (in preferences at the very bottom), the setting for [print.tab_modal.enabled] to FALSE in order to stop the PITA custom Print Dialog that Thunderbird uses, and get the default back to the system dialog... but setting this to FALSE also disables any Print function for the edit window. Argh!

Come on Mozilla. Please allow the System Print Dialog to be set to default!!! No need to play God anymore.

In Thunderbird 91.8.0 (64-bit) on Mac-OS Monterey M1 I often will "Edit Message as New" in order to print an email message with no headers. Now when in a Message Edit window, the "print" command does nothing. Also the "Print" icon, available on the edit window toolbar, does nothing. I have updated & restarted T-Bird, and restarted my Mac. Not sure when the problem started. Is there a preference that should be enabled? EDIT: Found the problem -- I had set, using Config Editor (in preferences at the very bottom), the setting for [print.tab_modal.enabled] to FALSE in order to stop the PITA custom Print Dialog that Thunderbird uses, and get the default back to the system dialog... but setting this to FALSE also disables any Print function for the edit window. Argh! Come on Mozilla. Please allow the System Print Dialog to be set to default!!! No need to play God anymore.

Modified by cwebb25