Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube video player and audio stops working when tabbed out or streaming

  • No replies
  • 1 has this problem
  • 2 views
more options

Hi Firefox staff,

This issue started ever since I updated my Firefox to version 98.1 and 98.2

Whenever I switch monitors or tabbed out while using another program on my desktop. The YouTube video will freeze and stop playing. I noticed this when I was livestreaming. The video seems to work fine on my end and I hear the audio however, my watchers in the livestream cannot hear or see the video. This never was a problem in the past. The freezing happens almost instantly when the window is not selected.

I have already tried to update to the latest and refresh to Firefox default settings in attempt to fix this. Enabling and disabling hardware acceleration doesn't change anything.

I have not tested this with other video players, but I do know it is apparent with YouTube. Please let me know if there is a manual fix to this or if Firefox needs a patch update to wait for :(

EDIT: I would like to delete my question I think I fixed the issue.

Hi Firefox staff, This issue started ever since I updated my Firefox to version 98.1 and 98.2 Whenever I switch monitors or tabbed out while using another program on my desktop. The YouTube video will freeze and stop playing. I noticed this when I was livestreaming. The video seems to work fine on my end and I hear the audio however, my watchers in the livestream cannot hear or see the video. This never was a problem in the past. The freezing happens almost instantly when the window is not selected. I have already tried to update to the latest and refresh to Firefox default settings in attempt to fix this. Enabling and disabling hardware acceleration doesn't change anything. I have not tested this with other video players, but I do know it is apparent with YouTube. Please let me know if there is a manual fix to this or if Firefox needs a patch update to wait for :( EDIT: I would like to delete my question I think I fixed the issue.

Modified by lon.quu1

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.