On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't Open .tiff in Firefox Browser

  • 2 replies
  • 1 has this problem
  • 146 views
  • Last reply by FireFoxFan1

more options

I could have sworn a week or two ago I was able to open .tiff files in the Firefox browser. But this week, when I click on a file, it goes straight to saving them to my computer. Is there a way to change this setting? I checked in my options, but did not see .tiff.

I could have sworn a week or two ago I was able to open .tiff files in the Firefox browser. But this week, when I click on a file, it goes straight to saving them to my computer. Is there a way to change this setting? I checked in my options, but did not see .tiff.

Chosen solution

You may be able to add .tiff files using the procedure outlined in the link below.

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions

It seems Firefox is now downloading all files, even if you only want to open them. A temporary 'fix' is outlined in the thread below.

https://support.mozilla.org/en-US/questions/1370494

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

You may be able to add .tiff files using the procedure outlined in the link below.

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions

It seems Firefox is now downloading all files, even if you only want to open them. A temporary 'fix' is outlined in the thread below.

https://support.mozilla.org/en-US/questions/1370494

Helpful?

more options

Okay, the solution in the first link added this file type to the application settings. I set it to "always ask" as it had been before, I believe.

Modified by FireFoxFan1

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.