Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly the Ongoing Downloads (from Download Button) stays open after download

  • 3 replies
  • 3 have this problem
  • 268 views
  • Last reply by rogéz

more options

So I have my Download button visible all the time.

Yesterday, this suddenly started to happen.

When I download something, the list of Ongoing Downloads stayed open. It never did that before.

Any idea why and how to fix it?

Windows 10, Firefox 98.0 (64-bit)

So I have my Download button visible all the time. Yesterday, this suddenly started to happen. When I download something, the list of Ongoing Downloads stayed open. It never did that before. Any idea why and how to fix it? Windows 10, Firefox 98.0 (64-bit)
Attached screenshots

Chosen solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified by Chris Ilias

Helpful?

more options

Thank you!

I actually just found the solution myself. I started looking for it in the about:config because I lost this post of mine. -blush-

Whyyyyy do they do these silly changes...

Helpful?

more options

Indeed, the same thing happened to me... every day a few times, this panel just opens out of itself, without me doing any download. weird behaviour.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.