Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox cache pages deleted afert day(s)

  • 3 replies
  • 1 has this problem
  • 10 views
  • Last reply by Terry

more options

Ever since I was forced to change to Windows 10 and the new update Firefox browser version the darn pages in history keep expiring after only a day or days so I can't view/load them when offline (except any open page left unclosed). They used to stay in cache for longer than that. I am sick of always having to come back online to re-load pages Firefox has expired after only a day or days or even only hours. (I don't mean the addresses/links in history list but the cached pages.) There don't seem to be any settings in options for this.

(Sorry I don't have time to search archives. Have too many troubles with WIndows 10 and related things like new browser version to keep looking them all up.)

Ever since I was forced to change to Windows 10 and the new update Firefox browser version the darn pages in history keep expiring after only a day or days so I can't view/load them when offline (except any open page left unclosed). They used to stay in cache for longer than that. I am sick of always having to come back online to re-load pages Firefox has expired after only a day or days or even only hours. (I don't mean the addresses/links in history list but the cached pages.) There don't seem to be any settings in options for this. (Sorry I don't have time to search archives. Have too many troubles with WIndows 10 and related things like new browser version to keep looking them all up.)

All Replies (3)

more options

Hello

You have to go into your settings, and change the expiry dates, from delete after one day change to don't delete. Then you can tell them delete after a certain amount of days, ..like 15 or 30 days, that should do it.

more options

Where are these settings? I can't see any setting like that in 'settings'. The only thing I've found is that it was set to custom settings in history, so I've set it to remember history, but I will have to wait for day(s) to see if that makes any difference, but it was already ticked both remember browsing history under custom settings anyway (and I am not sure if that is only history addresses/links or also recent cache pages).

more options

You could try changing this preference in about:config. I have never done so and have the default 180. browser.migrate.chrome.history.maxAgeInDays

EDIT: Sorry, I was following on from previous comments. There is another preference which may affect your original question. The subject seems to be a work in progress but you could try setting it to false. privacy.clearOnShutdown.history

Modified by Terry