Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 96 not loading pages, or even home page

  • 14 replies
  • 2 have this problem
  • 76 views
  • Last reply by James

more options

Submitting using Chrome, which may have to become my default browser.

Firefox 96.0. Windows 11 Pro Version 10.0.22000 Build 22000

Since installing FF 96, the program has stopped loading pages. Will not even load home page. Starting in troubleshooting mode sometimes works, but sometimes does not.

No extensions are installed.` I have tried Refreshing. I have uninstalled and reinstalled. Neither helps. Multiple instances of FF are started with every launch, even when the launch results in a blank page.

Any advice would be helpful.

Thank you,

Steven Sacks

Submitting using Chrome, which may have to become my default browser. Firefox 96.0. Windows 11 Pro Version 10.0.22000 Build 22000 Since installing FF 96, the program has stopped loading pages. Will not even load home page. Starting in troubleshooting mode sometimes works, but sometimes does not. No extensions are installed.` I have tried Refreshing. I have uninstalled and reinstalled. Neither helps. Multiple instances of FF are started with every launch, even when the launch results in a blank page. Any advice would be helpful. Thank you, Steven Sacks

Chosen solution

Uninstalling, rebooting, and reinstalling Webroot resolved the problem, confirming other online reports.

I used an install/uninstall problem (Revo), which cleans up leftover files and registry entries. It’s been suggested that this is important for ensuring the fix works. If you don’t use an uninstaller, instructions for manual clean-up can be found here: https://community.webroot.com/community-101-2/not-working-345896

Regards,

Steve

Read this answer in context 👍 0

All Replies (14)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

You can check for issues caused by a corrupted or incomplete Visual C++ installation that is missing runtime components (Redistributable Packages) required by Firefox, especially VCRUNTIME140_1.dll.

See "Visual Studio 2015, 2017, 2019, and 2022":

You may also have to install the Visual Studio 2013 Redistributable Package. You need to reboot the computer.

Modified by cor-el

more options

Thanks cor-el,

But...

“You can check for issues....”

Umm, actually maybe *you* know how to check. I have no idea how to do this. I can, however confirm that VCRUNTIME140_1.dll is installed.

“You may also have to install...” I may. Or may not. How do I determine whether I actually do?

Regards,

Steve

more options

Thanks Fred,

I just TURNED OFF my firewall. No difference.

(

Regards,

Steve

more options

steven.sacks said

I can, however confirm that VCRUNTIME140_1.dll is installed.

It's possible the program has problems. Use the posted links to install it again.

more options

Installed 97.0 Rebooted Installed VC_redist.x64.exe Rebooted Refreshed FF

Still no joy. Never works in normal startup SOMETIMES works in Troubleshoot Mode; when it doesn't, it stalls with lots of background processes

more options

Do you have Webroot Security?

more options

Ahhh...

Yes.

I tried turning off the firewall with v96. But that didn't change anything.

Ill try it again (with v97). Any other ideas?

more options

Quick preliminary update.

Turned off firewall. No difference. Completely deactivated it: Seem to be working (about 6 consecutive launches)

More soon....

more options

Hunh....

https://community.webroot.com/webroot-secureanywhere-antivirus-12/webroot-blocking-firefox-97-0-64-bit-350229 "I have a partial fix for this. The issue is outlined in here but the important bit is that WRusr.dll is ccalling SHGetFolderPathW in DllMain.

"The partial fix is to install Firefox 98 Beta Nightly that was released last night.  Once I installed that Firefox 64-bit would load once again.  The reason I’m calling this a partial fix is because you’re having to use a nightly build and because Firefox is patching a work around for a larger issue that Webroot needs to address to prevent issues with other programs.

"The very reason I switched to firefox a year ago was because this kept happening with Chrome, other software making workarounds for a webroot issue is not good."

Or... get another security suite.

Props to TyDraniu for the heads-up, and to FredMcD and cor-el for valiant attempts.

Steven

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

more options

What also seems to work is to uninstall and reinstall Webroot.

more options

Chosen Solution

Uninstalling, rebooting, and reinstalling Webroot resolved the problem, confirming other online reports.

I used an install/uninstall problem (Revo), which cleans up leftover files and registry entries. It’s been suggested that this is important for ensuring the fix works. If you don’t use an uninstaller, instructions for manual clean-up can be found here: https://community.webroot.com/community-101-2/not-working-345896

Regards,

Steve

more options

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations