Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

unwanted dark mode

  • 2 replies
  • 1 has this problem
  • 16 views
  • Last reply by carmanj

more options

Recently (past several months) firefox has been taking every light mode theme I choose and changing it to dark mode. Do. Not. Want.

Once a theme has been "changed", I can never use it in light mode again. So I'm left mode-hopping in the hopes of being able to get a readable light mode for a couple days, until I have to change again.

I've checked other questioners but their answers didn't solve this.

All Replies (2)

more options

You can fix this by selecting a theme that has dark text on the tabs instead of light text.

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

Thanks--this fixed part of the problem. Pages are again white with black lettering, which is a huge help.

But the bookmarks sidebar, and bookmarks management, are still dark. Is there another switch for this?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.