Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Slow Loading of large HTML Tables since Version 94

  • 7 replies
  • 1 has this problem
  • 10 views
  • Last reply by TyDraniu

more options

I have a webiste that loads a lot of data - over 2000 lines with 11 columns. In version 93: loads in 3 seconds. In any version after 93 loads in over 1 minute maybe 2.

Any idea why this is? This maybe a problem that has been reported but I cannot find reference to it.

I have had a lot of problems with FireFox today and I was forced to upgrade from 90 to 96. I hoped by missed 2 major releases that the problem would have been fixed. It hasn't. Any idea why?

I really do not want to move away from FF but it is very heavy and very heavy in terms of system resources but if this problem cannot be identified or remidied I may have to and let's be honest - who wants google to win?

I have a webiste that loads a lot of data - over 2000 lines with 11 columns. In version 93: loads in 3 seconds. In any version after 93 loads in over 1 minute maybe 2. Any idea why this is? This maybe a problem that has been reported but I cannot find reference to it. I have had a lot of problems with FireFox today and I was forced to upgrade from 90 to 96. I hoped by missed 2 major releases that the problem would have been fixed. It hasn't. Any idea why? I really do not want to move away from FF but it is very heavy and very heavy in terms of system resources but if this problem cannot be identified or remidied I may have to and let's be honest - who wants google to win?

All Replies (7)

more options

Interesting. Can you test it with mozregression? Thanks.

Helpful?

more options

Sorry TyDraniu. I did not receive an email to let me know anyone had responded. What setting do I need to tick to ensure that I receive an email when somebody responds? Talks about Threads not questions.

Anyway: I will have a look at this and test it.

Helpful?

more options

Build Info Window:

app_name: firefox build_date: 2021-09-08 21:16:44.353000 build_file: C:\Users\craig\.mozilla\mozregression\persist\4ae29776c6b9-shippable--autoland--target.zip build_type: integration build_url: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/R7IKVap6QxuCTeAb6yQNRA/runs/0/artifacts/public%2Fbuild%2Ftarget.zip changeset: 4ae29776c6b914009f87ce4f549a13d737bfe047 pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=aca153106940b800cac068609f552fc82b2ba2d1&tochange=4ae29776c6b914009f87ce4f549a13d737bfe047 repo_name: autoland repo_url: https://hg.mozilla.org/integration/autoland task_id: R7IKVap6QxuCTeAb6yQNRA

Helpful?

more options

Log Window (could not post it all):

2022-02-03T08:35:21.663000: INFO : platform_buildid: 20210906164526 2022-02-03T08:35:21.663000: INFO : platform_changeset: 7b46caa81caf41c857eeeddcdd8dacb34123bfe7 2022-02-03T08:35:21.663000: INFO : platform_repository: https://hg.mozilla.org/integration/autoland 2022-02-03T08:35:21.663000: INFO : platform_version: 94.0a1 2022-02-03T08:35:40.329000: INFO : b'[Parent 13792, IPC I/O Parent] WARNING: file /builds/worker/checkouts/gecko/ipc/chromium/src/base/process_util_win.cc:167' 2022-02-03T08:36:38.185000: INFO : Narrowed integration regression window from [aca15310, 3e3ac6f8] (3 builds) to [aca15310, 7b46caa8] (2 builds) (~1 steps left) 2022-02-03T08:36:38.195000: DEBUG : Starting merge handling... 2022-02-03T08:36:38.196000: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=7b46caa81caf41c857eeeddcdd8dacb34123bfe7&full=1 2022-02-03T08:36:38.196000: DEBUG : redo: attempt 1/3 2022-02-03T08:36:38.196000: DEBUG : redo: retry: calling _default_get with args: ('https://hg.mozilla.org/integration/autoland/json-pushes?changeset=7b46caa81caf41c857eeeddcdd8dacb34123bfe7&full=1',), kwargs: {}, attempt #1 2022-02-03T08:36:38.199000: DEBUG : urllib3.connectionpool: Resetting dropped connection: hg.mozilla.org 2022-02-03T08:36:39.208000: DEBUG : urllib3.connectionpool: https://hg.mozilla.org:443 "GET /integration/autoland/json-pushes?changeset=7b46caa81caf41c857eeeddcdd8dacb34123bfe7&full=1 HTTP/1.1" 200 None 2022-02-03T08:36:39.242000: DEBUG : Found commit message: Bug 1699217 - Implement @import layer|layer(<name>). r=boris

This works modulo the existing nested layer order bug. Will be covered by WPT /css/css-cascade/layer-import.html once the feature is enabled (I can probably enable it right away for those tests, but I'd rather fix the obvious bugs first).

Differential Revision: https://phabricator.services.mozilla.com/D124538

2022-02-03T08:36:39.242000: DEBUG : Did not find a branch, checking all integration branches 2022-02-03T08:36:39.247000: INFO : The bisection is done. 2022-02-03T08:36:39.252000: INFO : Stopped

Helpful?

more options

It's definitely worth reporting with a testcase and these regression log. Please create a new bug on https://bugzilla.mozilla.org/enter_bug.cgi .

Until it's fixed you can enter about:config in the URL bar and set "layout.css.cascade-layers.enabled" = false.

Helpful?

more options

I have created the bug report. The config change only helped marginally.

Thank you for your help.

Helpful?

more options

Modified by TyDraniu

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.