Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

RECENT RELEASE FORCED WHITE-ON-BLACK - DESTROYING PRODUCTIVITY.

  • 4 replies
  • 3 have this problem
  • 40 views
  • Last reply by wingrider6

more options

STOP DESTROYING MY 10-YEAR FAVORITE BROWSER BY FORCING WHITE-ON-BLACK!

All Replies (4)

more options

TRY TO CHANGE "LAYOUT.CSS.PREFERS-COLOR-SCHEME.CONTENT-OVERRIDE" TO 2 IN ABOUT:CONFIG.

more options

Hi Bill, Firefox 96 now harmonizes more parts of Firefox with your toolbar theme. When the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. It also signals sites that you have a dark theme preference.

What to do about this

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs such as:

https://addons.mozilla.org/firefox/addon/firefox-b/

I have attached a screenshot illustrating the difference between a theme with light text on the tabs and dark text on the tabs.


(At the risk of some duplication...)

Background / Other Settings

Firefox 95+ is taking more and more cues from your toolbar area theme for how to style other aspects of the browser. There is a setting for some of these, but not all of them.

(A) Right-click context menus, toolbar drop-down panels

Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

(B) Built-in pages, and websites that have light/dark responsive themes

Starting in Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme instead of your system theme. There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

more options

I have used Classic Blue on all my PC's for a long time and been very pleased with the results. Now my homepage (Google) is black as well as other pages. This really sucks. The alternative themes to recommend really suck. Tried the Golden Gate theme, thought it looked closed to Classic Blue but the blue was very disgusting. Why are we being forced into this crazy scheme?

more options

The recommendation about was to change layout... to 2, I tried 1 and I think that may do the trick.