Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Netflix

more options

Hi I am receiving an error in Netflix saying that my Firefox is not up to date. When i check my version I am

informed that it is the latest version 94.0.2 (64-bit) Netflix works in other browsers but, Firefox is my

preferred browser.

I have tried refreshing and reinstalling without success.

Your help would be appreciated.

...

Cheers

Ross

Hi I am receiving an error in Netflix saying that my Firefox is not up to date. When i check my version I am informed that it is the latest version 94.0.2 (64-bit) Netflix works in other browsers but, Firefox is my preferred browser. I have tried refreshing and reinstalling without success. Your help would be appreciated. ... Cheers Ross

Modified by James

Chosen solution

Hi Ross, Firefox uses the Widevine plugin to work with DRM (copy protected) media. The Netflix error could be a problem with using either a too-old or a too-new version of Widevine. Since Firefox normally updates Widevine automatically in the background, this problem may go away on its own, but there may be a way to speed that up.

Check for Updates

As a starting point, could you check your Widevine version on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. On the right side, find Widevine and click its title to open the details tab. This is mine for comparison -- do you have this version 4.10.2391.0 in your Firefox?

If you don't have that version, click the gear icon above the details to open a little menu, then click Check for Updates.

Any luck?

Disable DRM, then Re-enable

If that doesn't help, next thing to try would be disabling DRM on the Settings page, and then re-enabling it to try to force reinstallation of Widevine. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type drm and Firefox should filter to the "Digital Rights Management" section. Uncheck the box for "Play DRM-controlled content" and Firefox should uninstall your current version of Widevine. I don't know how quickly that happens, so give it a minute. Then check the box again to trigger a fresh installation.

Any luck?

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Hi Ross, Firefox uses the Widevine plugin to work with DRM (copy protected) media. The Netflix error could be a problem with using either a too-old or a too-new version of Widevine. Since Firefox normally updates Widevine automatically in the background, this problem may go away on its own, but there may be a way to speed that up.

Check for Updates

As a starting point, could you check your Widevine version on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. On the right side, find Widevine and click its title to open the details tab. This is mine for comparison -- do you have this version 4.10.2391.0 in your Firefox?

If you don't have that version, click the gear icon above the details to open a little menu, then click Check for Updates.

Any luck?

Disable DRM, then Re-enable

If that doesn't help, next thing to try would be disabling DRM on the Settings page, and then re-enabling it to try to force reinstallation of Widevine. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type drm and Firefox should filter to the "Digital Rights Management" section. Uncheck the box for "Play DRM-controlled content" and Firefox should uninstall your current version of Widevine. I don't know how quickly that happens, so give it a minute. Then check the box again to trigger a fresh installation.

Any luck?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.