On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Whitespaces in Thunderbird filter rules

  • 4 replies
  • 1 has this problem
  • 9 views
  • Last reply by p_gershon

more options

How do I enter whitespaces in Thunderbird filter rules, e.g.

Body Contains "Hello Dear."

I have tried the following:

Hello Dear. "Hello Dear." 'Hello Dear.'

None work. If I delete the whitespace then test the rule it works fine.

I am using Tbird 78.14.0 on Ubuntu 21.04.

This seems a very basic question. Needless to say there is no answer on line.

Thanks.

How do I enter whitespaces in Thunderbird filter rules, e.g. Body Contains "Hello Dear." I have tried the following: Hello Dear. "Hello Dear." 'Hello Dear.' None work. If I delete the whitespace then test the rule it works fine. I am using Tbird 78.14.0 on Ubuntu 21.04. This seems a very basic question. Needless to say there is no answer on line. Thanks.

All Replies (4)

more options

It works here in 78/W10, both with filters and Classic Search, Ctrl+Shift+F. I entered a few words separated by spaces, exactly as they appeared in the message body, without any quotation marks. Same result with the Quick Filter Bar, Ctrl+Shift+K. Does the filter log indicate any reasons why yours doesn't work?

more options

Hi sfhowes, Many thanks for your kind response.

I tried this with several different strings each containing a whitespace, all had been copy pasted directly from the message body then copy/pasted into filter rules, then copy/pasted back to a test email, none were filtered until I removed the whitespace then followed the same procedure.

To do the above tests, I created a new filter. BUT I did not create a new msgFilterRules.dat file. This file has three filters: The third one never worked because it has whitespaces, the first two are the diagnostic tests I am describing.

The filter log was entirely empty until I started sending myself test messages that had no whitespaces, then entries started appearing in the log. There are no entries for the non-filtering of messages that contain whitespaces. These are simply not recognized, it seems.

Do you think this is Ubuntu 21.04? Do you think I should create a clean msgFilterRules.dat? The latter file is not obviously corrupt, and does support filters without whitespaces.

It may help if someone had info on other versions of Ubuntu.

Thanks!

more options

I don't have a Linux system to test, but it might be easier to first try it with Classic Search, and just type in search strings having spaces without copying from messages. If it works with search but not filters, then you might conclude the filter dat file is damaged; deleting it from the account subfolder of the profile, while TB is closed, will create a new, empty file when TB restarts.

more options

Dear sfhowes, I think it was msgFilters.dat, I started a new one and whitespaces seem to work now in a single test.

I had written a Python script to generate a msgFilterRules.dat from a list of filter terms in a separate text file, and this msgFilterRules.dat was the one that was failing.

Tonight I modified this script from' type="48"' to 'type="17"' and also 'actionvalue='[my imap trash file] then tested the modified script and the msgFilterRules.dat from the modified script seemed to recognize whitespaces in a single test.

The journey was long but the education was good: I now have a script to successfully import filter terms if I need it.

Best regards and thanks very much for your response and your patience.