On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot get autocomplete to quit bringing up a site even though I've asked it to forget it

  • No replies
  • 1 has this problem
  • 1 view
more options

I've tried everything to get it to quit bringing up this site when I start typing. It is NOT in my bookmarks. "Shift Delete" does nothing except remove the letters that are selected. Telling it to forget the site in history also does not work. Yes, it removed it from history, but it still comes up as a suggestion.

Please help!

I've tried everything to get it to quit bringing up this site when I start typing. It is NOT in my bookmarks. "Shift Delete" does nothing except remove the letters that are selected. Telling it to forget the site in history also does not work. Yes, it removed it from history, but it still comes up as a suggestion. Please help!