Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox wont load unless i clear history

more options

Firefox doesnt load websites all of a sudden on my windows10 machine. I type a new website address and it just stays on the same site i was in. I try a new tab but no use.

Thru trial and error, i learnt that i click Menu->history->Clear history and then it works.

I have reset firefox and still it does not work. 94.0.01(64-bit version) is what i am running.

Driving me nuts..

All Replies (3)

more options

If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Type https://accounts.firefox.com/settings<enter> in the address bar. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

If any errors are reported: https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional

The places.sqlite file contains your History and Bookmarks. And it looks like it is corrupted.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox. The browser should then create a new place.sqlite and recover your bookmarks from the backup files.

Note: Your history is not backed up and will be lost.

Helpful?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

Helpful?

more options

Thanks both... Fred McD, your solution fixes the problem, but temporarily. something brings it up quite surely. cor-el, i couldn't tell what i causing it using the troubleshoot mode but i am still going thru that process. will update

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.