Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dropdowns on Google not working

more options

Just as was reported here, when I went to Google today, none of the famous "People also ask" dropdowns would work. Neither would any of Google's custom javascript widglets (I made that term up. They are likely Angular apps). This behavior also happened with some of the controls on my online bank's pages. This behavior is not present in Edge.

This is a new computer to me, and once recently, I lost control of some of Firefox's own menu items (I could scroll to items on the 3-bar menu, but not click some of them). Don't know if the two problems are related. The only thing that fixed that issue was to re-install Firefox.

I'm currently on Win 10, FF 94.0 (64 bit). I have tried all the standard advice: clearing cookies and cache, starting in troubleshooting mode, refreshing Firefox, and fiddling with performance settings (am I right that turning on and off hardware acceleration is no longer an option?).

Since I did try troubleshooting mode, I don't think this is caused by an extension, but who it possible for an extension to break FF, then have the broken behavior continue even after refresh? I'd really like to figure this out so I don't have to re-install the program every time this occurs.

Thanks for any help! -Josh

Attached screenshots

Modified by joshdewinter

All Replies (2)

more options

Okay....I'm not going nuts, but I literally closed the tab I had written this question on initially, then a couple more, and when I got back to the SAME tab the Google page in question was on, the dropdowns worked! I didn't change anything, and I had previously clicked thoroughly on those dropdowns to check their behavior prior to writing this question. It's looking like somehow, either there was an offending tab that was breaking functionality of OTHER tabs, or something I did in the deletion of cookies or cache took a while to have an effect, or maybe a shared memory effect of some kind was in play. VERY weird. What sorcery are the FF developers using that would cause this?

Modified by joshdewinter

more options

Hi Josh, stuff happens, doesn't it!