Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Automatic calls to many Google services on launch (Windows 10, desktop)

  • 13 replies
  • 1 has this problem
  • 61 views
  • Last reply by hiciya6568

more options

Hello! Something in my Firefox installation seems to be making several Google network (google.com / forcesafesearch.google.com / www.youtube-nocookie.com / m.youtube.com, and a couple of others) calls shortly after launch. I have a DNS sinkhole, so that is how I can see.

I have a few reputable extensions (or should be, from EFF, Firefox itself, or Ublock Origin), but it also happens in safe mode. I went through a good chunk of this: https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections and still the calls occur

I am on Windows 10, with FF v93.

Thanks very much!

Modified by hiciya6568

All Replies (13)

more options

Does the about:networking page show these requests (HTTP and DNS) ?

Helpful?

more options

Thanks for the prompt reply!

HTTP I did not, however on, DNS I saw these: youtube.googleapis.com. ipv4 false 64.233.185.95 71 restrictmoderate.youtube.com. ipv4 false 216.239.38.119 2086

Helpful?

more options

I don't think Firefox has any reason to contact YouTube at startup, unless maybe it is related to a shortcut in the built-in Firefox Home / new tab page. Otherwise, could it be related to an add-on?

Helpful?

more options

I start FF with a blank page, so unless there's something happening behind the scene I am unaware of.

If I run safe mode, would all extensions be totally disabled (or could they still make network calls)?

I'll try uninstalling and reinstalling add-ons to test it out (I am curious about what causes it, but I will probably refresh FF as well eventually).

As an aside, I see the calls made are all cnames related to SafeSearch and YouTube restricted mode (although I am not with an entreprise or have any sort of SafeSearch): https://learn.akamai.com/en-us/webhelp/enterprise-threat-protector/enterprise-threat-protector/GUID-0FCB1221-60DC-4A01-9B09-0C25B16BF3D0.html

Helpful?

more options

hiciya6568 said

If I run safe mode, would all extensions be totally disabled (or could they still make network calls)?

Totally disabled.

Helpful?

more options

You may have to use "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page in case of unexplained issues.

Helpful?

more options

Thanks jscher2000 and cor-el, help is appreciated!

Alas, clear the startup cache did not seem to help! I know this is just a minor annoyance, but, I am curious to know what is causing those calls (which I have since blocked).

I will try installing a fresh FF on a spare PC I have, and I don't mind doing a refresh as mentioned, but will try and figure out what the source is.

Are there any dev tools/extensions that might dig deeper into network calls FF makes?

Helpful?

more options

So I did the Firefox refresh, and, having just changed my start page/new tab to blank, all those Google calls persist (maybe not THE very first launch; that may have been just a www.google.com) but subsequent ones.

So, I think I'd need to dig into source code (which I know very little about), or get dev support!

Modified by hiciya6568

Helpful?

more options

Here are the calls, in case anyone else has a DNS sinkhole or alternative means to monitor outgoing connections specific to FF and is curious. Thanks!

Helpful?

more options

Hello! Sorry for the delay.

I installed FF fresh on a different PC, and it yields the same Google/YouTube network calls.

Any help would be appreciated! Thanks!

Modified by hiciya6568

Helpful?

more options

Your last screenshot says that DNS requests are being blocked. Probably that interrupts the process so you can't see what kind of request would ultimately be sent. That probably requires an HTTP proxy which can MITM the connections.

Helpful?

more options

Ah, okay, thanks for the information. Perhaps like Wireshark?

Helpful?

more options

So, finally figured it out, so it was due to the "Enable DNS over HTTPS" being enabled by default (and perhaps due to the provider it had selected that was the culprit).

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.