Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't play any video

  • 3 replies
  • 1 has this problem
  • 2 views
  • Last reply by FredMcD

more options

Hi,

from a day or two I can't play any video from facebook or youtube. It looks like is loading forever. I disabled all add-ons, but it didn't solve the problem. I have v93.0.

Do you have any ideas what I can do?

Modified by Emi

All Replies (3)

more options

Videos not Loading in Firefox? ... Solution 1: Disable Hardware Acceleration. ... Solution 3: Clearing Cache and Cookies. ... Solution 4:

Videos not Loading in Firefox?

It has been reported by numerous users that after getting an update to their Firefox, their browser is behaving oddly. They are not able to play any kind of video on any website, be it a dedicated video streaming website such as YouTube or any social media website. But this issue has been officially acknowledged and there are some workarounds available. Below are a few solutions to this problem. Firefox videos not loading. Solution 1: Disable Hardware Acceleration

The first thing we can try is disabling Hardware Acceleration from the settings. Although this feature is very useful but it can still be a bit buggy at times and disabling it can solve such problems. This solution requires you to restart your browser so it is recommended that you save all your work and bookmark important tabs so that you do not lose important data.

       First, go to your Firefox Options. By clicking on the three bars at the top right and selecting Options from the menu.
       Click on options.
       Once you are in the options, scroll down and you should see the Performance options.
       Uncheck from performance options.
       Uncheck Use Recommended Settings which will then show you the option to disable/enable Hardware Acceleration. Uncheck that as well.
       Disable hardware acceleration.
       Once you do, restart your browser.

Solution 2: Disable Add-ons

Sometimes it is your browser’s extensions that may be interfering with your websites and causing them to not work properly. You can try disabling your extensions and see if it works.

       First, go to the Add-ons by clicking on the three-bars on the top right. Or simply press CTRL+SHIFT+A.
       Click on Add-ons options.
       Then from the opened menu, go to Extensions.
       Select the extensions tab.
       Here you should see the list of extensions installed on your browser. Click on the three-dots against each extension and hit disable.
       Disable the extensions.
       Check if the problem is resolved. You may as well restart your browser although it is not required after disabling the extensions.

Solution 3: Clearing Cache and Cookies

Next, we can try clearing the cache and cookies of your browser.

       Once again, go to the Options.
       Click on options.
       From the options on the left side, navigate to Privacy and Security.
       Go to Privacy and Security.
        Scroll down and you should see Cookies and Site Data. From there click on Clear Data…
       Click on Clear Data.
       Check both options of Cookies and Site Data and Cached Web Content and hit clear.
       Check both and hit clear.
       Restart your Browser.

Solution 4: Enable Autoplay from Browser

For this next solution, head over to the website where your videos are not playing. Let’s take YouTube here.

PRO TIP: If the issue is with your computer or a laptop/notebook you should try using Restoro Repair which can scan the repositories and replace corrupt and missing files. This works in most cases, where the issue is originated due to a system corruption. You can download Restoro by Clicking Here

       Click on that padlock on the left side of your URL and click the Arrow Button.
       Click on the padlock.
       Next Click on More Information. This will open a new menu.
       Click on more information.
       From the opened menu, click on the Permissions tab.
       Select the permissions tab.
       Here you will see a list of permissions, from the Autoplay option, Uncheck User Default.
       Uncheck Autoplay.
       Then select the Allow Audio and Video radio button.
       Select the allow audio and video button.
       Restart the browser.

Solution 5: Refresh your Firefox

If everything fails, you are still left with the option to Reset your browser.

           From the three-bars on the top right, click Help.
           Click Help from the menu.
            Then click on troubleshooting information.
           Select the Troubleshoot option.
           On the right side, you will see Refresh Firefox…
           Click on the refresh button.
           Confirm your decision by clicking again on  Refresh Firefox.

Solution 6: Downgrade your Firefox.

Lastly, you have the choice to downgrade your Firefox. Since most users have reported that they faced this issue after updating. Downgrading should fix it until they fix the problem for good in the coming updates. Solution 7: Power-cycling Computer

Another useful workaround that worked for numerous users was where power-cycling the machine solved the problem instantly. It seems that there are some temporary configurations stored against Firefox which do not get erased until you restart your computer. Power Cycling Computer

Every application makes use of cache which is used to store information and data from different websites. If that cache is corrupt, you will not be able to play videos. To power-cycle your computer, simply turn off your computer completely, take out the power supply and wait for a few minutes before plugging everything back in. Solution 8: Enabling Autoplay

Firefox has a feature from which can limit how the website plays videos. It basically blocks all the videos from playing automatically as they usually do when they are launched up. During the process of stopping the video from auto-playing, the video player gets bugged and doesn’t play videos anymore. Here, we will navigate to the website where videos are not playing and enable autoplay.

   Navigate to the problematic website.
   Now, click on the green lock present at the start and enable the autoplay function there.
   Enabling auto-play
   Save changes and reload the website and see if the issue is resolved. If this doesn’t work yet, power-cycle your computer.

Solution 9: Switching Internet Access

If none of the above solutions work, what you can do is change your internet access to a faster broadband connection. Firefox has a known problem where because of weak internet access, the videos stall, and instead of playing with buffering, they don’t play at all.

If you don’t have faster internet access, try connecting your system to your mobile data using a hotspot. If videos start playing in a different connection, consider updating your network and see if this fixes the problem. Bonus: Installing Additional Codecs (Ubuntu)

If you are missing codecs from your Ubuntu system, Firefox will not be able to play videos in the browser window. Ubuntu, unlike other operating systems, doesn’t have an automatic codec installation system and you need to manually install them from here. Make sure to restart your system before trying to play videos again. https://appuals.com/how-to-fix-videos-not-playing-in-firefox/

Helpful?

more options

Hi, I tried every suggestion and nothing works. Today I updated firefox to v94 and the issue persists. On other laptop, it works perfectly. I uninstalled firefox, deleted all related files and registries and installed again, but it didn't solve the issue. I don't know what to do anymore.

Modified by Emi

Helpful?

more options

If you have Windows 10 N or KN then you may not have the Media Feature Pack installed. https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.