Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

php based web site no longer displays correctly in Firefox but is OK in other browsers

  • 3 replies
  • 1 has this problem
  • 11 views
  • Last reply by kenw4

more options

I have a home website that was written using php well over 10 years ago. Except for family updates, it has changed little and displayed correctly using firefox and other browsers. Firefox is my preferred browser. A couple of months ago, it stopped displaying correctly in firefox but continues to display correctly w/o issues in Edge, and other browsers.

I note it displays in a basic form in firefox, links to other pages and content are shown and operable, but not displayed (correctly) as it does in Edge and others. I am on the latest version of Win Pro 10.

I posted the problem the end of August and received a number of suggestions. I went through the steps suggested (using troubleshoot amongst other suggestions) and none of the suggestions resolved the issue. My suspicion is that something in a relatively recent update of firefox has issues with my php based code. I do not use a "web tool" but write the source myself. I started writing websites with html decades ago and got the bug to use php years back.

If anyone has the interest (or curiosity) to look at the website in firefox and edge and my source code and see if they see the issue I would be glad provide the link to my website.

Chosen solution

For reference, the prior suggestions: https://support.mozilla.org/questions/1349303

Are you using an http:// or https:// address for the page, or loading it from a local file using a file:// address?

Are there any interesting messages in the Web Console when you load the page? You can open that using Ctrl+Shift+K, or follow the steps in this article: https://developer.mozilla.org/docs/Tools/Web_Console

Read this answer in context 👍 0

All Replies (3)

more options

Firefox doesn't know about PHP code and has never processed PHP code natively. You will always need to use a local server or a web server to process the PHP code and send the resulting HTML code to the browser as text/html. If this worked before, but stopped working then it sounds that this server no longer works or you aren't using it.

Helpful?

more options

Chosen Solution

For reference, the prior suggestions: https://support.mozilla.org/questions/1349303

Are you using an http:// or https:// address for the page, or loading it from a local file using a file:// address?

Are there any interesting messages in the Web Console when you load the page? You can open that using Ctrl+Shift+K, or follow the steps in this article: https://developer.mozilla.org/docs/Tools/Web_Console

Helpful?

more options

FYI, I use http and have been lazy not to change over to https.

I removed the Firefox version I had and loaded the current version from the mozilla website. The website now displays OK. So, basic PHP source works OK on this version.

As it is a family site, it is viewed by pretty much all of the browsers from desktops, laptops, tablets, and Android/Apple phones (multi generations). Some family members still use Win 7 and the old MS explorer.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.