Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

spell checker does not work

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

Tried ticking the box in preferences

Tried the about:config

changed it to 2 and it is still not working on my new macbook pro

version 10.15.7

macOS Catalina

All Replies (2)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

Helpful?

more options

Note that you can (should) update to Firefox 78.14.0 ESR as that version is still supported for MacOS 10.9. Any specific reason for using Firefox 57 ?


Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

You can look here for dictionaries:

Note that you may have to look for an older dictionary version for your Firefox 57 version.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.